View Full Version : [ubuntu] Not able to connect Olympia Omega 2038 Printer ... Anybody help...!!!

January 18th, 2011, 10:23 AM
Dear friends,
I was a windows OS user. After going through Ubuntu website in 2010 I have tried installing Ubuntu 10.04 and started using it. After few weeks of working on it, I became addicted to it and I completely love it. Recently I have upgraded to 10.10 and its looking great and I'm loving it. I was able to connect everything except connecting Olympia Omega 2038 printer to my computer.
I had the same issue while using Ubuntu 10.04 and now I had the same issue with 10.10. I searched all the forms and googled for months on searching of an answer but I couldn't get a right answer. I know there are Ubuntu experts and Ubuntu lover out there reading my post. Can anyone of help me in fixing this issue for once and all. Now I'm really feed up of trying to connect and each and every time when ever I want to print something I have to copy that into my flash and connect to my windows machine and have to print. I don't want to go through all this hassle. Somebody please help me. Below are the details

My machine :-

Assemble computer
Running Ubuntu 10.10
32 Bit

Trying what ?

Trying to connect Olympia Omega 2038 printer through network.
This printer is connected to Windows machine, which is shared in the network. Both the windows and linux machine are connected on the same network.

Steps tried:-

System >> Administration >>Printing >> Add >>LPD/ LPR Host or Printer>> added the host IP and tried searching for the correct drivers.
But Omega is not mentioned in the given list

Thank you for any help in advance

January 18th, 2011, 11:43 AM
the first thing to do is checking ubuntu detection: is that hardware well identified ?



Then you need to know if that printer is known whith a different name/trademark