PDA

View Full Version : [SOLVED] No Internet Access Via Terminal Using VPN Connection



ziphi
January 18th, 2011, 04:52 AM
Hello forums,

this is not exactly urgent, but I stumbled upon this problem from time to time and finally decided it bugs me enough to post this:

My Internet connection works.

Using no VPN connection, I can access the Tnternet from the gnome-terminal (ping, apt-get, lynx), as well as from any GUI application.

As soon as I establish a VPN connection via openconnect, GUI applications such as firefox, transmission and thunderbird still work.

But terminal applications (such as mutt, apt-get etc), some daemons (like mpdscribble) and some GUI applications (such as the easytag cddb search) don't work anymore.

This is probably just a matter of fetching connection settings, but I'd still appreciate help!

Thanks,
ziphi

ziphi
January 19th, 2011, 09:02 AM
Bump, anyone?

I'm not sure, but this should also occur using console based torrent clients, like rtorrent. Very annoying. Any help?

ziphi
January 20th, 2011, 12:44 AM
Okay, shame on me: I thought the terminal didn't have internet connection while connected via VPN client, but it actually does: mutt and ping and still work. Only apt-get and some other (gui) programs don't work. I will mark this as solved, but would be happy about any feedback on apt-get!