View Full Version : [SOLVED] Dell Inspiron (1525) broadcom fix, Lucid Lynx

January 17th, 2011, 08:04 PM
I've been to all the threads and tried everything, but nothing worked until I found a comment on a blog somewhere.

I have a Dell 1525 with the BCM4315 chip and I am running Lucid Lynx.

I have the "wireless disabled" issue, nothing I do will activate the wireless card, except this:

1. Turn the computer off.
2. Slide the wireless switch to the off position.
3. Reboot the computer.
4. Slide the wireless switch on

This works every single time and it takes me from having no options for wireless connectivity to being 100% online.

This tells me that all of the drivers and configurations are correct (enough) and that the issue doesn't seem to be some basic driver/config issue.

Is there any way I can avoid having to toggle a switch before and after boot so that I can use wireless? Am I missing some startup option?

If I turn the computer on with the wireless switch enabled, nothing I do (even sliding it back and forth) will cause the wireless card to start working.

I had issues with this in previous versions of Ubuntu, but nothing as stubborn as this round.


January 17th, 2011, 08:16 PM
I have this same laptop, and have 0 problems with wifi. I just updated to Maverick from Lucid, neither had any issues. Perhaps an update or reinstall might fix your problem? I have a bog standard install, the only thing I can think of that might have an effect is I have never used the ethernet in Linux on this machine (it's a triple boot Win7/Ubuntu/OSX Snow).

January 17th, 2011, 08:58 PM

I upgraded to Maverick since there wasn't a reason not to and I'm up and running.

I'll just slowly back away from this one.

Thanks for the response.