View Full Version : [ubuntu] 10.04 and 10.10 recurringly crash (target system does not have requested /sbin/init )

January 16th, 2011, 08:24 PM
Hi - After trying most of the solutions I could think of, including reinstalling and upgrading, I'm posting here hoping someone would take me out of this misery now.

Laptop:thinkpad t500

I was running Ubuntu 10.04 and it froze. I rebooted and it shows the following message and gives me the "initramfs" prompt:

BUG: unable to handle kernel paging request at 00f44000
mount: Mounting /dev on /root/dev failed: No such file or directory
mount: Mounting /sys on /root/sys failed: No such file or directory
mount: Mounting /proc on /root/proc failed: No such file or directory

Target filesystem doesn't have requested /sbin/init
No init found. Try passing init= bootarg

Here are the things that i've tried:

Fresh Installed 10.10 from live cd and in 2 days this happened again on 10.10 as well.
Tried to run fsck from live cd and it doesn't want to run as it thinks the device/resource is busy or mounted
Tried to run recovery mode from GRUB and it comes and stops at initramfs prompt as well.

I am more interested in getting to the root of this because a fresh install just doesn't seem to help. It happens again and again - every 2-3 days. And I'm using my Laptop in the most basic way. Browsing and coding.

Please help me as this is really affecting my work now.



January 16th, 2011, 09:42 PM
This could be a graphics card driver problem, but I can not find anything to say which card the laptop contains. Do you know? If not run
sudo lshw -c display
and report the output back here.

Perhaps there's a problem with your ram?

From grub choose memtest86+ and let it run overnight. At the bottom it will report the number of errors, if any, and anything above zero shows there is a problem with one or more of your memory sticks.

If you have more than one stick of ram, remove each of them separately, one by one, and use the memtest again overnight with each running. If you get just one stick with errors, replace it with a new one, and hopefully all will then be well again.