View Full Version : [ubuntu] Failed to initialize the NVIDIA graphics device

January 15th, 2011, 03:41 PM
hi i am kinda new to linux so i dont know how to fix this problem. I installed an update for my graphics card through the Additional Drivers in ubuntu 10.10 64 bit and when i restarted the computer, after ubuntu loaded it brought me to a black screen with white writing that asked me for username and password and then said that it failed to initialize the NVidia graphics device. is there a way to repair this or rollback the driver with some code? Please help asap. Thanks in advance.

January 15th, 2011, 05:59 PM
open a terminal, then run:

sudo rm /etc/X11/xorg.conf

reboot (power off)

if problem is still there, inside synaptic, remove/purge (right click) ALL the installed nvidia packages then reinstall : nvidia-current, nvidia-common, nvidia-settings

reboot again then check driver activation

January 15th, 2011, 08:38 PM
Thanks bro. it worked

January 15th, 2011, 08:39 PM
thanks bro. it worked