View Full Version : [SOLVED] Alarm Clock in Panel?

January 13th, 2011, 02:00 PM
I must be overlooking something here, but I can't find out how to add "Alarm Clock Applet" to my panel. In Ubuntu Software Center, there's a picture of the program right in the panel and feature to add to panel, but there's no option for me to do this. "Add to Panel" doesn't have the application either.

It should appear in your notification applet. Start up the application with
/usr/bin/alarm-clock-applet Have it start up at boot by right clicking on the alarm clock and select preferences and select 'start automatically at logon'.
Thanks matt_symes (http://ubuntuforums.org/member.php?u=1067998)!

Ubuntu 10.10 x64
alarm-clock-applet 0.3.1-1

Frogs Hair
January 13th, 2011, 03:44 PM
An alarm clock applet can be found in the software center.

January 13th, 2011, 03:47 PM
sudo apt-get install alarm-clock

January 13th, 2011, 05:17 PM
I'm not sure from your post if you have installed it or not.

If not install it.

Then if it doesn't show up on the panel, find it in your application menu, right click on it, and you'll get several options, including "add to panel"

January 13th, 2011, 05:37 PM

sudo apt-get install alarm-clock-applet

That is what i use. I don't know if it differs from those suggested above.


If you can't add it to the panel open a terminal and type


or log out and log back in and see if appear in the 'add to panel' option.

Kind regards

January 14th, 2011, 12:30 PM
Hello everyone, sorry for the confusion. The application is installed and running on my computer. I just can't find the option to add to panel. What's the command to restart gnome, like we use to do with restarting metacity.


January 14th, 2011, 12:33 PM
gnome-panel --replace &

January 20th, 2011, 04:50 PM
gnome-panel --replace &
Didn't work before or after restart. When I input that into the terminal, it says it doesn't exist even though I can load up the program and use it no problem. Just no panel app icon.


January 21st, 2011, 12:14 PM

What is the output of

ls -l /usr/lib/alarm-clock-applet/

That is small L above.

Kind regards

January 22nd, 2011, 05:04 PM
It doesn't exist, but the program is installed on my computer. I open the application by the terminal with this command 'alarm-clock-applet'.


January 22nd, 2011, 05:27 PM

Open a terminal and type

sudo updatedb

then enter your password. Let it update then type

locate alarm-clock-applet

Post the path back here. I'm interested to know where it's installed on your system

Kind regards

January 23rd, 2011, 12:01 AM
Here's the output:

locate alarm-clock-applet


January 23rd, 2011, 01:02 PM

I am beginning to think you might have a different version of the alarm-clock-applet than i have.

matthew@matthew-laptop:~$ locate alarm-clock-applet

As you can see, after a purge and reinstall this is where it has put the files and they are at a different location (with other files) than yours. The version i am using is 0.2.6-2 from synaptic.

BTW: I am using 10.04 so maybe that is the issue.

You installed the alarm-clock-applet from synaptic package manager ?

Kind regards

January 24th, 2011, 04:04 AM
I installed it from Ubuntu Software-Center version 0.3.1-1 (alarm-clock-applet). We are differently on different versions, but I wonder, why my version isn't including the panel add-on.


January 24th, 2011, 04:27 AM

I have just booted into 10.10 and installed the alarm-clock-applet and i see your problem. You do not get that problem with 10.04 and the lower version of the applet.

I will have a play. If i get success i will post back.

Kind regards

January 24th, 2011, 05:04 AM

There is a difference in behaviour between the version for 10.04 and 10.10 but i have managed to get it working in 10.10.

In 10.04 you can add it as a panel applet, however in 10.10 it appears differently. This is what i did.

In the terminal i typed

/usr/bin/alarm-clock-appletIt appeared as an notification applet on the right (looks like an alarm clock). Right click on the alarm clock and select preferences and select 'start automatically at logon'. You can set the alarm by left clicking on it and selecting the + button on the left.

This should fix it for you.

Please see attached screenshot

Kind regards

January 24th, 2011, 09:50 AM
Hello again Mr. matt_symes,
With your help and a little troubleshooting. I finally got it working! Pretty much, it wasn't updating the notification for me. I wasn't sure why, but all I had to do was re-add my notification applet and it finally showed up! I would never thought about that.

Side Note:
On installation, the alarm clock is already set to start up by default. Did you get this as well?


February 12th, 2011, 09:04 AM
Here are a few issues on getting Alarm Clock Applet by Pseudoberries to work, after installing, as far as I can see...

As of this date, Synaptic Package Manager only installs 0.2.6 and Update Manager does not update it any higher than that. On the same date, the Pseudoberries website encourages you to (a) install it more "by hand" and (b) install version 0.3.1

Some versions of alarm-clock-applet (or is it some versions of Ubuntu?) put it in
while other versions of the applet (or Ubuntu?) put it in

The executable alarm-clock-applet program resides in a directory of the same name.

Using Synaptic Package Manager on Ubuntu 10.4.1 to install AlarmClockApplet 0.2.6 did NOT result in it being seen in Applications > anything (e.g. Accessories, System Tools, nor Ubuntu Software Center) (even after rebooting) unlike some of the advice out there on the subject.

Trying to run the program from the terminal...
(1) Are you logged in as your normal self, or as sudo? (Does that make any difference?)
(2) If you don't remember to type ./ before the alarm-clock-applet it will say program not found (or some such) even when you are right in the correct directory.
(3) With me running AlarmClockApplet 0.2.6 from a terminal session on Ubuntu 10.4.1 it only resulted in the terminal freezing up until I did some Ctrl-D or similar. It did not result in the AlarmClockApplet appearing anywhere in the GUI environment, unlike some advice out there.

The bottom of http://alarm-clock.pseudoberries.com tells you to go to
The launchpad project page https://launchpad.net/alarm-clock/ for bugs & questions
Where, cleverly hidden in one of the threads often repeated on this problem, the creator Johannes H. Jensen (https://launchpad.net/%7Ejoh) explains to newbies that THIS is what you do to the applet once it is installed...

Along the panel at the very top of your screen:
Left click in a blank area.
Right click.
Choose Add to Panel
Choose Alarm Clock
Choose Add

At this point I finally got the AlarmClockApplet icon in my panel, and I could start using it.

Cheers, Carl, New Zealand