View Full Version : Linux Puppy won't Boot

January 13th, 2011, 03:28 AM
Hi there, I'm an oldie/newbie trying to get around the command line in Ubuntu, and have tried as many distros as I can get my hands on, many thanks to "Ubuntu User" Magazine and their articles. The latest I'm tring is Puppy on a relic of another decennie, A Dell C610 Laptop with a whopping 256m of RAM, a 20Go HD and a 1.2mHz processor. To date, all the platforms I've tried on this thing freeze up, not enough RAM, apart from Karmic Koala, even then the windows don't close properly half the time. Then I came across "Puppy" v. 5.20! Very light and fast, perfect for this Crapasaurus. So, I went through the install, following the instructions for a "Frugal" install, since my first attempt with basic install didn't stick. I used advice for the GRUB configure from various threads and sites, and finally got it to the point where it would give me the boot option screen. I would select "Puppy" and it would give me the following message: /bin/sh: error while loading shared libraries:/lib/libtermcap.so.2 : File too short
Then the next line reads: Kernel panic. not syncing: attempted to kill init.

is there a thread or someone who can guide me through the installation, I would really like to know where the problem is, apart from behind the keyboard, so I can salvage this little laptop.