View Full Version : [SOLVED] Firewall prevents connection to Synology NAS

January 8th, 2011, 03:05 PM
I am having difficulty connecting to my new Synology DS211j NAS unit using Connect to Server. When the ufw firewall is active, I receive the following error:

Cannot open location "smb://myuserid@diskstation/backups/"
Failed to mount Windows share

When the firewall is disabled, it works fine. Results of "sudo ufw status" command is:
Status: Active

9997:9999/udp ALLOW Anywhere
135,139,445/tcp ALLOW Anywhere
137,138/udp ALLOW Anywhere

Since I am a recent convert to LINUX, I need some assistance in troubleshooting this problem. Can someone school me in the activation and research of a log that will help diagnose my problem? I am not familiar with any of the logging mechanisms of LINUX. Any help will be appreciated.


Frogs Hair
January 8th, 2011, 04:20 PM
If you have the UFW GUI known as fire wall configuration installed from the software center , it is possible to set rules and enable logging which appears in the log file viewer.

Frogs Hair
January 8th, 2011, 04:28 PM
Sorry ,link failed try these.


January 10th, 2011, 10:10 PM
Thanks, Frog Hair! Using examples from the link you gave me, I entered the following command:

Sudo ufw allow from x (where x is the IP addr of my Synology NAS)

The Connect to Server now works!!!!

January 10th, 2011, 10:14 PM
glad it worked out. looks like you were blocking access to samba. I have a very similar synology, and didn't have to do anything to make it work, but i had already installed samba on the boxes that were connecting so the samba install probably had already opened the ports. samba's data stream is udp based so makes sense that the allow would have to be bidirectional.