PDA

View Full Version : [SOLVED] Need help with Canon PIXMA MP490 on ubuntu 10.10 - scans but doesn't print?!



evergreenoflife
January 8th, 2011, 12:57 PM
Hi! I'm new to the forums but I've had ubuntu running for a while now. I'm a total newbie though and don't know any of the fancy terminal commands and what not.

Anyhow, the issue I'm having is with my new Canon PIXMA MP490 printer. I've searched the forums up and down and found only few threads about this printer and none of the solutions given there worked for me. I'm using Ubuntu 10.10.

I've followed these instructions (http://ubuntuforums.org/showpost.php?p=9779266&postcount=8) given by jkeane, however I did not install the ScanGear for Linux (1.4) because for some unknown reason my MP490 scans like magic already (with SimpleScan). It's only the printing that is making me bang my head on the wall;

If I go to "System" - "Administration" - "Printing" it shows my printer in there and it is able to tell whether it is offline or online as well.

If I try to print something, (most of the time) it shows up in "Document Print Status (my jobs)" - and it shows the process or at least says "processing". Yet my printer does nothing.....?

Any ideas on what is wrong and what I could do to fix it? I'll bake you cookies all year long if you can fix my printer/ubuntu!!

Otherwise the printer works well, scans well and copies well - just that it doesn't print :( which is kinda the function I bought it for, lol. The thing is I wouldn't want to switch back to windows now, just cause of a printer. I'm loving ubuntu and all the nice features it has.

Thank you so so much for anyone who can offer their help! It's really appreciated!

evergreenoflife
January 8th, 2011, 03:21 PM
Is there any way I could make the printer work through wine or something? Anyone?

SOLVED! :)

s4ncho
February 28th, 2011, 10:19 PM
SOLVED! :)
but how!!??

heavy metal
March 9th, 2011, 06:43 AM
Install the canon Linux drivers for your printer here:
http://www.canon.com.my/

WanderingAlbatross
March 24th, 2011, 07:06 PM
There's no Linux driver listed at the Canon website. It is only windoze and Mac.

WanderingAlbatross
March 24th, 2011, 07:22 PM
We used this link from Asia's Canon website (http://support-th.canon-asia.com/contents/TH/EN/0100236305.html)
It started a loop in terminal that would keep asking you for the printer, and say it wouldn't find one. Once it did this, though, the computer recognized the printer and printed fine.