PDA

View Full Version : [ubuntu] package & dependency problems - can't fix!!



wiseguy12851
January 3rd, 2011, 04:19 AM
I'm having a big problem with dependencies all of a sudden, I've never encountered this situation before - It seems packages with dependency problems somehow got installed and synaptic didn't detect them, but that's really the best guess I can come up with.

The problem I'm facing is there are no corrupt or broken packages, everything works great with the exception that anytime I perform any task on new or existing software it completes the task and then starts to complain about recovering from errors on an installation I asked it to do a long time ago.

The weird thing is, if I ask it to do something like install fonts for example, they end up getting installed (or at least most of it installed) but it still complains about errors and recovering from them.

Here is the error message that came up in a dialog at the very end:

E: xemacs21-nomule: subprocess installed post-installation script returned error exit status 1
E: aplus-fsf-el: dependency problems - leaving unconfigured
E: xemacs21-mule-canna-wnn: subprocess installed post-installation script returned error exit status 1
E: xemacs21-mule: subprocess installed post-installation script returned error exit status 1
E: haml-elisp: subprocess installed post-installation script returned error exit status 1
E: xemacs21: dependency problems - leaving unconfigured

W: Ignoring file 'apt-build' in directory '/etc/apt/sources.list.d/' as it has no filename extension
W: Ignoring file 'apt-build' in directory '/etc/apt/sources.list.d/' as it has no filename extensionit seems that whenever I try to just completely purge all of the xemacs21 stuff above it might purge some installations but one of these has to be installed all the time, as when I purge one thing the other has to be installed.

additionally the error message does differ depending on which packages I did manage to remove or purge.

Nuihc88
April 18th, 2011, 11:54 PM
I have the same problem with the same packages.

Nuihc88
April 21st, 2011, 03:58 AM
I was able to solve this problem with the following terminal command:

sudo apt-get purge xemacs21 xemacs21-nomule xemacs21-mule xemacs21-mule-canna-wnn xemacs21-bin xemacs21-supportel xemacs21-gnome-mule xemacs21-gnome-nomule xemacs21-gnome-mule-canna-wnn xemacs21-support xemacs21-basesupport xemacs21-mulesupport xemacs21-basesupport-el xemacs21-mulesupport-el
It only works when it's all one line, otherwise it just goes in a loop.

dkozhukhar
April 25th, 2011, 11:40 AM
I was able to solve this problem with the following terminal command:

sudo apt-get purge xemacs21 xemacs21-nomule xemacs21-mule xemacs21-mule-canna-wnn xemacs21-bin xemacs21-supportel xemacs21-gnome-mule xemacs21-gnome-nomule xemacs21-gnome-mule-canna-wnn xemacs21-support xemacs21-basesupport xemacs21-mulesupport xemacs21-basesupport-el xemacs21-mulesupport-elIt only works when it's all one line, otherwise it just goes in a loop.
Thanks for your idea.

I make the same with modification: put 'xemacs21' to the end of line, that purges it.