View Full Version : [SOLVED] Spooky file access error

January 2nd, 2011, 12:14 PM
Yesterday my friend's computer started to behave weird in relation to file writes:

When she want to write to an existing file using an application (we have tried meld, bzr extmerge and aptana studio) it didn't change the file on the harddrive... no warning was given. She tried with gedit once, and that worked, mysteriosly.

We wanted to examine the problem, so we tried changing directory to a folder witch she has read and write access to, but then we got a permission error:

julie@laptop:~/bachelorprojekt/repo/trunk/src/src$ ls -l
total 440
-rw-rw-rw- 1 julie julie 1784 2010-12-31 12:59 clock.pyc
-rw-rw-rw- 1 julie julie 3756 2010-12-31 15:09 dataTypes.py
-rw-rw-rw- 1 julie julie 4051 2010-12-31 15:21 dataTypes.pyc
drw-rw-rw- 2 julie julie 4096 2010-11-15 15:56 deprecated
-rw-rw-rw- 1 julie julie 1612 2010-12-31 12:55 dmCache.py
julie@laptop:~/bachelorprojekt/repo/trunk/src/src$ cd deprecated/
bash: cd: deprecated/: Permission denied
julie@laptop:~/bachelorprojekt/repo/trunk/src/src$ sudo su
root@laptop:/home/julie/bachelorprojekt/repo/trunk/src/src# cd deprecated/

this is very weird as she clearly has the rights to access the 'deprecated'-directory.

January 2nd, 2011, 12:22 PM
Actually, she doesn't have the permission to enter the directory. For that, you need the execute permission, but she only has read and write permissions. See e.g. here (http://articles.techrepublic.com.com/5100-10878_11-1047531.html) or here (http://www.linux.com/learn/tutorials/309527-understanding-linux-file-permissions).

January 2nd, 2011, 04:17 PM
Thank you!

Giving the owner and group execution rights also solved the problem with changing the files using an application.

January 3rd, 2011, 12:56 AM
You are welcome. Can you please mark the thread as solved (under thread tools above the first post), so that other helpers here know not to divert their energy and others seeking advice know that it is to be found here.