View Full Version : [ubuntu] NVIDIA - About to go nuts

December 31st, 2010, 02:53 AM
Ok, I've been scouring forums for weeks, trying different solutions and drivers and what not, and am absolutely not getting anywhere. I'm at the point where after a good ten years of Linux I'm ready to return to Windows, because I am disappointed in Ubuntu 10 and this problem is really not helping. So, here is my last effort I am going to make on this:

I had a Ubuntu 9.10 installation that worked well, but I updated it to 10.10 and now the nvdia driver refuses to work, which means, no Open-GL, no compiz, etc. My graphics card is an NVIDIA GeForce MX4000 (which should work with driver version 96)

If I go to the hardware (additional) drivers, I have two drivers there:

"NVIDIA accelerated graphics driver (version current)" and

Both are not activated.

If I activate the first one, Startx will crash and tell me it can't find the module "nvidia". If I activate the second, it says, it's activated but not running. There are hundreds of threads on here about this problem, and nothing has helped.

I have tried to completely remove any trace of nvidia on my system and reinstalling it. I've tried the nvidia driver from the nvidia site (which complains that I don't have the kernel sources installed, even when I enter the path to them), I have tried a different version of the driver, and an old backup file from my 9.10 system and nothing seems to work.

My current xorg.conf looks like this:

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"

Section "Module"
Load "glx"

Section "Device"
Identifier "Default Device"
Driver "nv"
Option "NoLogo" "True"

this at least gets me into X, but when I try to run nvidia-xconfig it tells me that I am not running the nvidia driver.

This is my xorg.conf, when I activate one of the drivers:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Tue Jul 13 13:31:50 PDT 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"

but even that doesn't work. I am pretty tech savvy, but this is getting to me. Is there an easy step by step approach that would get me some answers?

December 31st, 2010, 03:10 AM
My guess would be something went astray during the upgrade process.I have had similar problems when upgrading with the drivers enabled and finally just did a back-up on my data then wipe and re-install.As you said you have spent a fair amount of time trying to fix this if you can actually get it fixed and it only takes an hour or so for the re-install. For the latest drivers and such you can check the link below......


December 31st, 2010, 03:31 AM
I used to have a problem with Nvidia drivers. Extra visual effects would freeze the dialog boxes. The Nvidia configuration setup would not save any changes. Solution? A completely fresh install with a format of the root partition and the Home partition. Old configuration files were causing conflicts. I failed to de-activate the Nvidia drivers before doing an upgrade.


January 14th, 2011, 02:53 AM
Thank you. That was the solution in the end.Just a pain in the proverbial. :-) Thank you for your help