View Full Version : [ubuntu] Install on a ThinkPad T400

December 31st, 2010, 01:49 AM
I would like to install Ubuntu 10 on my Thinkpad T400, but would like feedback from other T400 users that have Ubuntu running on their laptops.

First, will it recognize all my hardware? I hear most Thinkpad users had issues with video and webcam drivers, but that was with an earlier version of Ubuntu 8 through 9.

So my plan is to have Ubuntu 10 as my primary OS on the T400 and use Win7 within VMware.

Any advise would be greatly appreciated!

Thanks all!


January 2nd, 2011, 02:58 PM
I have two Thinkpad T400 and they both work fine with Ubuntu.

I just did fresh install on Ubuntu 10.10 last night and everything works great.

One question though, battery icon (in the the panel next to the clock) always shows that battery 30-35 mins remain until battery is fully charged. Detailed power statistics show that the battery is charging (97.7% at the time of writing this), the time to fully charged isn't changing.

I believe that Ubuntu 10.10 comes with thinkpad_acpi module. Does anyone know is thinkpad_acpi has anything to do with weird battery status behavior?

Thanks a lot.

January 5th, 2011, 03:18 PM

Thanks for the feedback and I look forward installing Ubuntu on my T400. I'll also do some research on the battery issue.

January 5th, 2011, 03:18 PM
By the way, have you tested your webcam with Skype while running 10.10?

January 7th, 2011, 07:38 PM
i have not used webcam with skype but i did test it with gmail video chat and it worked fine.

for time being i have removed linux from my laptop because i am very obsessive about battery life. let me know if you come up with any solutions. thanks.

January 11th, 2011, 07:23 PM
You may find something useful within this link based on your battery concerns...


February 7th, 2011, 05:10 AM
I just installed 10.10 on a Thinkpad T400 with discreet graphics configured in the BIOS and I can't even get the thing to boot properly after initial install. If I leave it at discreet BIOS, I get the Ubuntu boot splash screen and it goes through a whole mess of weird color changes and never actually finishes booting. No HD activity whatsoever.

If I go into the BIOS and turn on integrated graphics, then It gets farther in the boot process and hangs in checking battery status.

Has anyone seen either of these issues. I connected to wifi before install and told it to install updates.

Very frustrating. I had Fedora 14 on here before and decided to give it a switch.

May 2nd, 2011, 01:43 PM
I had the same issue on my T400.. i fixed it be enabling one or the other.. if you have both enabled at the same time ubuntu throws a hissy fit and refuses to work