PDA

View Full Version : [SOLVED] no partition can't boot



cmcanulty
December 30th, 2010, 11:48 PM
I have been having progressively worse problems with one of our desktop library computers and then it stopped booting. I could load the Ubuntu CD but it won't install so I used puppy CD which will run in live mode and deleted the partitions to format them new. Big mistake! Now puppy won't let me repartition them so I have no MBR no partition. I can't boot knoppix either but it seems if I can use puppy and even connect to web on it there ought to be a fix for Ubuntu. I am typing this on another machine please help we close at 7pm and I really need to get this fixed or at least start thank you

TeoBigusGeekus
December 30th, 2010, 11:53 PM
Could it be a failing hd?

skyzthelimit230
December 30th, 2010, 11:59 PM
sounds like either a failing hdd, or a logic failure in which case you might have to reformat the entire drive

cmcanulty
December 31st, 2010, 12:00 AM
I really doubt that as things got drastically worse when I tried and failed to reformat /. But i have puppy live on and it doesn't see any hard drive!I was trying to reformat / and got errors so I deleted it and planned to reformat a fresh partition but now puppy only see the cd drive.

TeoBigusGeekus
December 31st, 2010, 12:03 AM
Let's try to eliminate hardware malfunction first.
Turn it off, unplug it, open the box and try unplugging and replugging the hard disk. Could be a circuit overloading, who knows?

cmcanulty
December 31st, 2010, 12:05 AM
ok trying that

cmcanulty
December 31st, 2010, 12:21 AM
OK no difference

cmcanulty
December 31st, 2010, 12:25 AM
OK now I have a /formatted to ext 4 and a swap do I need anything else and how do i repair boot

TeoBigusGeekus
December 31st, 2010, 12:27 AM
Ok, so when you boot up with ubuntu (or puppy) nothing appears as a hard drive?
If so, try to connect the drive to another computer, even a windows one, to see if it's recognized.
I insist on the hard disk failure, even considering the fact that it got worse after your formating attempt. Perhaps it was too much for the poor thing...

EDIT: Just read your last post. You could create a separate home partition and install grub; you should be ok after that.

cmcanulty
December 31st, 2010, 12:33 AM
InstallingGRUB is what I don't know, I've always used the ubuntu CDs whuch worked and did that. When I reboot from puppy cd it now shows /dev/sda1 ext 4 73GB and /dev/sda2 linux swap 3gb but it still won't boot from HD or Ubuntu CD but puppy runs fine live. I supposedly installed puppy just now but won't boot without the puppy cd

TeoBigusGeekus
December 31st, 2010, 12:38 AM
Go to this (https://help.ubuntu.com/community/Grub2) page and scroll down to reinstalling grub2 from live cd.

cmcanulty
December 31st, 2010, 12:40 AM
OK will that work from puupy cd as the ubuntu cd, I tried several won't go live

TeoBigusGeekus
December 31st, 2010, 12:44 AM
I don't know, does puppy use grub2 or legacy?

cmcanulty
December 31st, 2010, 12:48 AM
Well we have to close I will try again later thanks for all your help!

TeoBigusGeekus
December 31st, 2010, 12:50 AM
Don't mention it.
Just post us with your progress.
Good luck!

cmcanulty
December 31st, 2010, 02:42 PM
I am going to mark this thread solved and start one on the GRUB issue from puppy thanks again