PDA

View Full Version : [SOLVED] Unable to open PDF files since upgrade



Bobhuber
December 20th, 2010, 08:10 PM
Unusual problem. Since upgrading from 10.04 to 10.10 I am unable to open up any PDF files with document viewer as root. If I open nautilus with gksu,then attempt to open a PDF file it does nothing. I can go to Places from the main menu and right click on the file and open it just fine.I've checked the file properties and they are correct.

3Miro
December 20th, 2010, 08:23 PM
You can try to delete /root/.gnome2/evince, hopefully this will help.

Opening .pdf files as root is a very bad idea. Why would you ever need to do that?

Bobhuber
December 20th, 2010, 10:13 PM
You can try to delete /root/.gnome2/evince, hopefully this will help.

Opening .pdf files as root is a very bad idea. Why would you ever need to do that?
Didn't help. Thanks.
The question is not why I want to but why the file wont open. Some more insight into the problem. Forget about the PDF file. Evince won't open at all as root even from a terminal.

oarion7
December 20th, 2010, 10:38 PM
Didn't help. Thanks.
The question is not why I want to but why the file wont open. Some more insight into the problem. Forget about the PDF file. Evince won't open at all as root even from a terminal.

What kind of output do you get when trying to run it from the terminal? Or does it just hang?

Uninstall and reinstall evince through sudo in the terminal via apt-get?

Bobhuber
December 20th, 2010, 11:26 PM
What kind of output do you get when trying to run it from the terminal? Or does it just hang?

Uninstall and reinstall evince through sudo in the terminal via apt-get?
Did that. No luck.Heres the terminal error.

No protocol specified
Cannot parse arguments: Cannot open display:

If I open evince from a standard terminal it works fine.

Frogs Hair
December 20th, 2010, 11:32 PM
Try right clicking the pdf document and select open with another application ,select document viewer and make sure the remember this application box is checked.

wilburg
March 14th, 2011, 10:59 PM
My evince will not open either from the gui or from a terminal. I get a 'no protocol specified' in a terminal and simply nothing in the gui. No warning, no error, nothing. Help here would be useful.

fonsi2099
June 22nd, 2011, 03:22 PM
I have that:
"Unable to open document. File type unknown (application/octet-stream is not supported.)"

Thank you for replay

:guitar:

Bobhuber
June 22nd, 2011, 03:38 PM
I have that:
"Unable to open document. File type unknown (application/octet-stream is not supported.)"

Thank you for replay

:guitar:
Since I looked for days before finding the answer I'll give you a clue.
/etc/apparmor.d
edit the usr.bin.evince and the /abstractions/evince files

fonsi2099
June 23rd, 2011, 04:01 PM
Sorry, It has not worked and I noticed that the o-oficce docs are not opening too, it is asking for ASCII filter options and after the doc is completly not readable
Thank you
:KS

fonsi2099
July 28th, 2011, 08:07 PM
Please update that thread to UNSOLVED.

"Unable to open document. File type unknown (application/octet-stream is not supported.)"
Thank for any help

:guitar: