View Full Version : [ubuntu] Linksys WMP54G SLOW SLOW SLOW!!

December 10th, 2010, 09:35 AM
I have a Linksys WMP54G wireless PCI card in my desktop PC. I am lucky to get 1 Mbps after the PC has been running for an hour or more. I can run a laptop on the same wireless network at the same desk as my desktop and conistently get 10-12 Mbps downloads.

In doing my Google research, it appears that anything Cisco/Linksys is very Linux unfriendly. There HAS to be something that will fix my PC without having to change my wireless card... right?

lspci output: Network controller: RaLink RT2561/RT61 802.11g PCI

I have been to Ralink's website, but cannot find an installable driver (tarballs are for geeks who understand how to use the command line blindfolded). Us everyday PC users need something user friendly.

Any suggestions other than a sledgehammer?!

December 24th, 2010, 01:08 AM
Cant say that I have a solution to your problem, but I am experiencing the exact same thing.

December 28th, 2010, 10:38 PM
Ever find a solution? I tried the default RT61 driver that Ubuntu 10.10 auto-detected. This driver works, but is very, very slow. I just tried updating it with the windows XP driver using ndiswrapper, but the speed seems to be the same. I'm not sure what else to try...I could take the windows vista driver and try it...but I don't have much faith in it working.

Any other ideas? I can't stand how slow this is and I usually boot into windows with this family computer because the wireless card works fine in windows 7.

EDIT: My card is ver4.1