PDA

View Full Version : [ubuntu] 10.10 Won't recognize my other SATA hard drives



Rock`
December 8th, 2010, 11:09 PM
I've got 3 hard drives on SATA, my main SSD (which it boots off of) and two other 2TB SATA drives that Ubuntu cannot find. Windows 7 has no issues seeing these drives and I've written about ~1TB between the two of them and have accessed the data recently (i.e. 5 minutes ago).

Here's the output of sudo fdisk -l


255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xdf8af63a

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 102400 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 13 6193 49635620 7 HPFS/NTFS
/dev/sda3 6193 9730 28410881 5 Extended
/dev/sda5 9578 9730 1218560 82 Linux swap / Solaris
/dev/sda6 6193 9578 27191296 83 Linux


that's my main drive partitioned for Linux/Windows (the SSD), but it has no other SDB/SDC [i assume thats how they are named].

Any ideas?

To help, my motherboard seems to set my storage drives as 'pass through IDE', I have no idea why or how to turn it off, I've updated the BIOS to the most current. The motherboard is Asus P6X58D Premium


Alllllllllso, I have 6gb of RAM which Ubuntu says I only have 4 (and subsequently, Windows does as well), but something like CPU-Z tells me I have the correct 6.

Any help is appreciated!

Fafler
December 8th, 2010, 11:30 PM
Please start by posting the output from:

lspci
dmesg | grep sd

The 6 gb problem can probably be solved by using either a 64 bit OS (if you have a 64 bit CPU) or a PAE enabled kernel. It could also be a BIOS issue. I once had a motherboard that needed a special BIOS parameter set in order to detect memory above 4 gb correctly. I can't remember what it was called, though.

As for the PAE kernel:

uname -a

If the string it returns doesn't contain the word PAE, you need to install another kernel with these commands (i'm at a Debian box right now and can't be more specific):


apt-cache search kernel pae

Choose the image file, where the version matches your current kernel version and install it. It could look similar to:

sudo apt-get install linux-image-2.6.32-5-686-bigmem
Reboot and enjoy. If that is what's wrong.

Rock`
December 12th, 2010, 11:32 PM
Please start by posting the output from:

lspci
dmesg | grep sd

The 6 gb problem can probably be solved by using either a 64 bit OS (if you have a 64 bit CPU) or a PAE enabled kernel. It could also be a BIOS issue. I once had a motherboard that needed a special BIOS parameter set in order to detect memory above 4 gb correctly. I can't remember what it was called, though.

As for the PAE kernel:

uname -a

If the string it returns doesn't contain the word PAE, you need to install another kernel with these commands (i'm at a Debian box right now and can't be more specific):


apt-cache search kernel pae

Choose the image file, where the version matches your current kernel version and install it. It could look similar to:

sudo apt-get install linux-image-2.6.32-5-686-bigmem
Reboot and enjoy. If that is what's wrong.

here's the output:

:~$ dmesg | grep sd
[ 2.762962] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 2.763011] sd 0:0:0:0: [sda] 156301488 512-byte logical blocks: (80.0 GB/74.5 GiB)
[ 2.763040] sd 0:0:0:0: [sda] Write Protect is off
[ 2.763042] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 2.763057] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 2.763144] sda: sda1 sda2 sda3 < sda5 sda6 >
[ 2.764115] sd 0:0:0:0: [sda] Attached SCSI disk
[ 3.084955] Adding 1218556k swap on /dev/sda5. Priority:-1 extents:1 across:1218556k SS
[ 5.572630] sd 4:0:0:0: Attached scsi generic sg2 type 0
[ 5.573068] sd 4:0:0:1: Attached scsi generic sg3 type 0
[ 5.615789] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[ 5.619564] sd 4:0:0:1: [sdc] Attached SCSI removable disk


I see sdb/sdc, those must be it..anyway of mounting it/accessing it?

Also, I'm running a 64bit OS (sorry should have specified), I think it may be a bad stick, but I'll work on that issue first, I just need to get these SATA HDs up!

Rock`
December 13th, 2010, 04:14 AM
Ah, nevermind. I tried sudo mount /dev/sdb(c) /mnt and I didn't get it to work :\, I don't think those are my SATA HDs. Any other thoughts?

CadetD
December 24th, 2010, 01:42 AM
This seems to be a problem with 10.x that isn't being addressed. There are many threads on it with no solutions. As if it is missing the SATA drivers.

cascade9
December 24th, 2010, 08:15 AM
Probably too late, but I'll post this anyway.


Also, I'm running a 64bit OS (sorry should have specified), I think it may be a bad stick, but I'll work on that issue first, I just need to get these SATA HDs up!

You should see 6GB with 64bit, and I'd be concerned about the missing RAM, but OK, deal with the HDDs.

I'll bet you've hooked up your SATA drives to the Marvell 9123 controller (the light blue SATA ports) move them over to the darker blue potrs, and I'm pretty sure your HDDs will work.

CadetD
January 6th, 2011, 01:57 AM
[...]

I'll bet you've hooked up your SATA drives to the Marvell 9123 controller (the light blue SATA ports) move them over to the darker blue potrs, and I'm pretty sure your HDDs will work.

I can still boot any previous Ubuntu version on my machine. Just not 10.10.

Here is the output of DMESG when booted from 10.10 disk:


ubuntu@ubuntu:~$ dmesg | grep sd
[ 9.358969] sd 6:0:0:0: Attached scsi generic sg1 type 0
[ 11.159953] sd 6:0:0:0: [sda] Attached SCSI removable disk
[ 11.777976] sd 8:0:0:0: Attached scsi generic sg3 type 0
[ 11.779455] sd 8:0:0:0: [sdb] 3907049984 512-byte logical blocks: (2.00 TB/1.81 TiB)
[ 11.780384] sd 8:0:0:0: [sdb] Write Protect is off
[ 11.780387] sd 8:0:0:0: [sdb] Mode Sense: 10 00 00 00
[ 11.781035] sd 8:0:0:0: [sdb] Cache data unavailable
[ 11.781037] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 11.783889] sd 8:0:0:0: [sdb] Cache data unavailable
[ 11.783891] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 11.783900] sdb: sdb1
[ 11.794128] sd 8:0:0:0: [sdb] Cache data unavailable
[ 11.794144] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 11.794148] sd 8:0:0:0: [sdb] Attached SCSI disk
ubuntu@ubuntu:~$ dmesg | grep sd
[ 9.358969] sd 6:0:0:0: Attached scsi generic sg1 type 0
[ 11.159953] sd 6:0:0:0: [sda] Attached SCSI removable disk
[ 11.777976] sd 8:0:0:0: Attached scsi generic sg3 type 0
[ 11.779455] sd 8:0:0:0: [sdb] 3907049984 512-byte logical blocks: (2.00 TB/1.81 TiB)
[ 11.780384] sd 8:0:0:0: [sdb] Write Protect is off
[ 11.780387] sd 8:0:0:0: [sdb] Mode Sense: 10 00 00 00
[ 11.781035] sd 8:0:0:0: [sdb] Cache data unavailable
[ 11.781037] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 11.783889] sd 8:0:0:0: [sdb] Cache data unavailable
[ 11.783891] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 11.783900] sdb: sdb1
[ 11.794128] sd 8:0:0:0: [sdb] Cache data unavailable
[ 11.794144] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[ 11.794148] sd 8:0:0:0: [sdb] Attached SCSI disk



So it sees the disks. But when I try to install only the Firewire-attached external drive is shown.