View Full Version : [SOLVED] X resetting at login (Dell Latitude C840)

December 8th, 2010, 08:36 AM
Hi, I have been trying all day and night to get the Nvidia drivers working in my Dell Latitude C840. It has a GeForce4 440 Go and the notorious 1600 x 1200 LCD screen with the bad EDID (for lack of a better term).

I specified a custom EDID for the card, and told it to use "DFP" as the primary display device. I also learned the hard way that the nvidia-96 drivers don't work with Ubuntu 10.10, so I am using 10.04.1 (no updates have been installed yet)

When I have the Nvidia driver specified in my xorg.conf file the system starts to boot. The boot splash is garbled, but once X loads up it looks fine - and looks to be running in 1600 x 1200. I have it set to automatically log me in on boot up. About halfway through the login sound the screen goes blank for a second and I am presented with the login screen. Attempting to log in again results in the same thing. I can switch to a virtual terminal an log in to play with the xorg.conf file, but again, the display is corrupted, there is light blue lines after every character on the screen. Recovery mode also has the corrupted screen.


# X -configure


# nvidia-xconfig

do not solve the problem

here is my current xorg.conf (the only difference from when I am having problems is that the nv driver is specified right now instead of the nvidia driver)

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder75) Thu Apr 15 05:52:31 PDT 2010

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"

Section "Module"
Load "extmod"
Load "glx"
Load "record"
Load "dbe"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"

Section "Device"

Option "UseDisplayDevice" "DFP"
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]
#Option "FPDither" # [<bool>]
#Option "CrtcNumber" # <i>
#Option "FPScale" # [<bool>]
#Option "FPTweak" # <i>
#Option "DualHead" # [<bool>]
Identifier "Card0"
Driver "nv"
VendorName "nVidia Corporation"
BoardName "NV17 [GeForce4 440 Go]"

Section "Screen"

Option "CustomEDID" "DFP:/etc/X11/nvnew.raw"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "False"
### Available Driver options are:-
SubSection "Display"
Viewport 0 0
Depth 1
SubSection "Display"
Viewport 0 0
Depth 4
SubSection "Display"
Viewport 0 0
Depth 8
SubSection "Display"
Viewport 0 0
Depth 15
SubSection "Display"
Viewport 0 0
Depth 16
SubSection "Display"
Viewport 0 0
Depth 24

You'll notice that I set NoLogo to false. In doing this I realized that X was resetting itself when I tried to log in (the Nvidia logo flashes right after the screen blanks).

I have also tried it by specifying "DFP-0" instead of "DFP" but there was no difference.

A couple other things to note is that recovery mode when using the nv driver appears to be running in 1600 x 1200 screen resolution, where when using the nvidia driver it is at a significantly lower one.

The other ting is that one time when I was editing the xorg.conf file (using nano) in recovery mode the computer locked up after a bunch of stuff scrolled up the screen. It looked like it was related to the internal wireless card. The original wi-fi card was an Agere-based 802.11b card, but I swapped it for a Broadcom BC4306 Rev. 3 (this card was originally from an HP).

Let me know if you need any more information, and thanks in advance!

December 9th, 2010, 01:16 AM
Update: I am getting a garbled display when using the nv driver now, and the resolution in recovery mode is not 1600 x 1200.

Update #2: I am getting an error regarding xorg being unable to load GLX. Its very similar to this: http://forums.fedoraforum.org/showthread.php?t=223413

I also noticed that the /usr/lib/xorg/modules/extensions/nvidia directory does NOT exist on my computer. I am looking in to this now.

December 9th, 2010, 03:31 AM
I have no idea what the problem was, but I managed to solve it by using the sgfxi script to install the driver.

Here's the website for the script: http://smxi.org/