View Full Version : [SOLVED] 10.10, 0.24 & firewire

December 6th, 2010, 04:03 PM
I'm making progress on rebuilding my backend. Last major stumbling block is getting the hdpvr running, channel changing is done via firewire.

I had it running on the old (10.04 & 0.23) box so I know it works. I was able to get on the old drive and copy the 6200ch which we tweaked to work with this STB a long time ago.
It is a motorola 6200 STB, but if I remember correctly it's ID was not in the file.

Anyway, I'm working to get this part running again and all the wikis are so out of date even the tools they suggest won't come up in 10.10.

Any assistance would be greatly appreciated as this is the last step before I have a running system again. Thanks in advance.

December 6th, 2010, 07:07 PM
I've copied the old 6200ch file over and put it in the command line for channel changing.

When I do a cat > I do get a file that is playable.

When myth does it, I get a recording, but it's x'd out and when I try to play it says 'recording unavailable...the file for this recording can not be found'

When I try live TV I get a green screen. Channel changing does not work. When I change input to another tuner (pvr 500 or 350) it does work and works pretty well too. Recordings work from the other tuners too.

What's the magic to getting this thing working?

December 6th, 2010, 08:04 PM
still working on this...

What I found is that when i set the channel change command to /bin/true I can watch live TV.

So I started chasing the channel change command.

Booted to the old system, /var/local/bin/6200ch 21 changes the channel, works fine.

Booted to new system, /var/local/bin/6200ch tells me 'no such file or directory'.
Weird, I can clearly see the file, why would the system not be albe to see it?

I think this is my problem, now if I can just figure out why the file isn't found when it's there I think I'd be in the gravy.

December 6th, 2010, 09:04 PM
it would seem I have to recompile it on this machine with the files for 10.10...

now how the heck do I find the contrib files

December 6th, 2010, 09:32 PM
gave up on the 6200ch and went with mythchanger

problem solved