PDA

View Full Version : [ubuntu] OpenVPN bridge question



hugetivofan
December 5th, 2010, 05:40 AM
Hi, have an openvpn bridge up and running (ubuntu to ubuntu, both in vmware fusion machines on macs). my problem is that i cant get a connection faster than ~9mbps even though 20+mbps is available. ive been troubleshooting for a while and have tried many fixes. i just now did ethtool tap0 and i think maybe i found it. it says the link is 10mbps. i tried to change it with:

sudo ethtool -s tap0 speed 100

but it says ethtool cant change speed on tap0. How can i define the link speed of tap0? Many thanks for any help.

hugetivofan
January 3rd, 2011, 08:15 AM
bump - anyone out there with a suggestion?

PatchesTheCaveman
January 3rd, 2011, 08:39 AM
Your connection is being limited by VMware, not Ubuntu:
http://kb.vmware.com/kb/1002456

hugetivofan
January 4th, 2011, 04:38 AM
Thanks for the reply. I am having trouble installing vmxnet3 driver using vmware tools and config. here is the output when i run vmware tools config - I did some googling and it seems like this is a problem others have encountered, but I am not sure how to fix it. Any help would be appreciated!

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-root/modules/vmxnet-only'
make -C /lib/modules/2.6.35-22-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. \
MODULEBUILDDIR= modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.35-22-generic'
CC [M] /tmp/vmware-root/modules/vmxnet-only/vmxnet.o
/tmp/vmware-root/modules/vmxnet-only/vmxnet.c: In function ‘vmxnet_load_multicast’:
/tmp/vmware-root/modules/vmxnet-only/vmxnet.c:2795: error: ‘struct net_device’ has no member named ‘mc_list’
/tmp/vmware-root/modules/vmxnet-only/vmxnet.c:2805: error: ‘struct net_device’ has no member named ‘mc_count’
/tmp/vmware-root/modules/vmxnet-only/vmxnet.c:2806: error: dereferencing pointer to incomplete type
/tmp/vmware-root/modules/vmxnet-only/vmxnet.c:2807: error: dereferencing pointer to incomplete type
make[2]: *** [/tmp/vmware-root/modules/vmxnet-only/vmxnet.o] Error 1
make[1]: *** [_module_/tmp/vmware-root/modules/vmxnet-only] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-22-generic'
make: *** [vmxnet.ko] Error 2
make: Leaving directory `/tmp/vmware-root/modules/vmxnet-only'

The fast network device driver (vmxnet module) is used only for our fast
networking interface. The rest of the software provided by VMware Tools is
designed to work independently of this feature.
If you wish to have the fast network driver enabled, you can install the driver
by running vmware-config-tools.pl again after making sure that gcc, binutils,
make and the kernel sources for your running kernel are installed on your
machine. These packages are available on your distribution's installation CD.