View Full Version : [ubuntu] autoconf.sh missing

December 4th, 2010, 05:55 PM
Hi All,

I have installed Ubuntu 10.10 recently, and the kernel version is 2.6.35-23-generic. I am not able to locate autoconf.h file in my /usr/src/linux/headers-2.6.35-23-generic/include/linux folder.

I tried installing autoconf package using "apt-get install autoconf" command too, but I did not see that file in the above location after the install. Can someone please tell me where I can find this file?


December 4th, 2010, 05:58 PM
i never wondered about that :)

what is your goal/target

December 4th, 2010, 06:19 PM
I was trying to compile one program which has dependency on the existence of this file. Its giving me the following error coz this file is not present -

Making module
make -C /lib/modules/2.6.35-23-generic/build SUBDIRS=/home/preethi/Downloads/testvpn/vpnclient modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.35-23-generic'
CC [M] /home/preethi/Downloads/testvpn/vpnclient/linuxcniapi.o
/home/preethi/Downloads/testvpn/vpnclient/linuxcniapi.c:14: fatal error: linux/autoconf.h: No such file or directory
compilation terminated.
make[2]: *** [/home/preethi/Downloads/testvpn/vpnclient/linuxcniapi.o] Error 1
make[1]: *** [_module_/home/preethi/Downloads/testvpn/vpnclient] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-23-generic'
make: *** [default] Error 2

December 14th, 2010, 11:28 PM
What worked for me:

Scroll to post 13.