View Full Version : [ubuntu] annot login to Ubuntu virtualbox, no display

December 3rd, 2010, 05:06 AM

So I have spent some time playing with this, and am not even sure what specific category the problem should go under. But let me describe what's going on.

I run Ubuntu 10.10 on an Oracle VirtualBox. Last night, I compiled my own kernel cause I am doing some work on the ext3 file system. However, the compile exited with error 2 and since then I am not being able to login to my existing installation. Below I describe what I have tried:

When it first would not let me login, I pressed Alt+Ctrl+F1 and managed to enter the generic installation. All files are intact, including the kernel source I was trying to compile. However, when I try to launch any application it just says "Gtk warning: cannot open display". I tried installing the ubuntu-desktop using apt-get, but that spits out "no space left on device"

So I am not really sure what the real problem is here. Cannot login, cannot open display, no space? Any help would be highly appreciated.

Thanks so much in advance!