View Full Version : [SOLVED] Last 10.10 System Update Messed Up Bluetooth Adapter

December 3rd, 2010, 02:56 AM
I am running 64 bit Maverick. Everything seemed to be working correctly for quite awhile. I have a Broadcom usb dongle attached to my system and it has worked fine from 9.10 on up.

After the last system update, which I think included a kernel update, the adapter does not load correctly on boot. When the boot sequence is finished, it takes the system 3 or 4 minutes to load the bluetooth configuration and have the icon present with a working wireless mouse. Before this upgrade I had bluetooth right away when the login screen appeared.

I have reinstalled bluetooth and bluez in synaptic, but no change. Any ideas on what I can check? I have a bluetooth mouse attached and it used to work fine but it drives me crazy that it is not usable right at login. After bluetooth finally loads, the mouse works as it always has. Looking at the boot logs, bluetooth and connecting to the mouse are the last entries in the boot sequence. I have been using Ubuntu for a couple of years but am still a novice at reading the logs.

Any help would be greatly appreciated.