PDA

View Full Version : HOWTO: TeamSpeak (with teamspeak:// links!)



JConnell
February 21st, 2005, 06:13 AM
Download the linux client from the TeamSpeak website (http://www.goteamspeak.com/downloads.php)



user@ubuntu:~ $ tar -jxf ts2_client_rc2_2032.tar.bz2
user@ubuntu:~ $ cd ts2_client_rc2_2032
user@ubuntu:~ $ sudo chmod 755 setup.sh
user@ubuntu:~ $ sudo sh setup.sh

Install to: /opt/TeamSpeak2RC2 (Should be the default)



user@ubuntu:~ $ sudo ln -s /opt/TeamSpeak2RC2/TeamSpeak /usr/bin/
user@ubuntu:~ $ TeamSpeak

Congratulations, TeamSpeak is now installed!



If you want to open "teamspeak://" links with firefox:

Launch firefox and type about:config in the address bar

Right-click and select New->String
Name: "network.protocol-handler.app.teamspeak"
Value: "TeamSpeak"

Right-click and select New->Boolean
Name: network.protocol-handler.external.teamspeak
Value: "true"

Now you can open teamspeak:// links, which will automaticly launch TeamSpeak and connect to the specified server when you click them! :D

KingArthur10
April 23rd, 2005, 06:58 PM
Thanks for the help! Finally got TeamSpeak working. :-) Thankee again!

sOnIc
July 1st, 2005, 03:28 PM
Hi!
I follow all steps but when i try to run TeamSpeak...


sonic@ubuntu:~$ TeamSpeak
Qt: Locales not supported on X server

What it means ?? (im absolutely new to linux) :roll:
Sorry about my bad english :-#
Cheers sOnIc

scruffy
December 13th, 2005, 01:22 AM
Works perfectly for me :D

Thanks

All the best..scruffy :D

Cogito
April 30th, 2006, 07:51 PM
Getting an error on when I try and run the installer binary.
Any suggestions?



user@ubuntu:~/ts2_client_rc2_2032$ sudo sh setup.sh
setup.sh: line 19: setup.data/installer/installer: cannot execute binary file

BlastXng
May 6th, 2006, 03:00 AM
Getting an error on when I try and run the installer binary.
Any suggestions?



user@ubuntu:~/ts2_client_rc2_2032$ sudo sh setup.sh
setup.sh: line 19: setup.data/installer/installer: cannot execute binary file


Try what was first shown above. I had problems with TeamSpeak after I used AutoMatix to install some software. I had to re-install TeamSpeak twice to get it to work. I followed the information at the begining of the post.

Neonsolid
May 6th, 2006, 10:29 AM
*

Sakhaara
December 3rd, 2006, 12:37 AM
Thanks man :-D :-D :-D

stu_u2k
January 3rd, 2007, 10:20 PM
I have tried installing it multiple ways & i just cant get the Autoinstall to work or the manual install either, i am abit of a ubuntu n00b so maybe its something silly.

I going to paste what i have tried, i have also had a mate SSH in & look at it, thou he's much more Gentoo orientated than ubuntu & he was lost too.

First of all i will show you the Auto Installation problem...

"USER@COMPUTER:~/Desktop/teamspeak$ sudo sh setup.sh
setup.sh: 14: Syntax error: Bad substitution"

After trying loads of different things the *automated* way i gave up & thought i would install it the manual way, so i have copied the contents of "/image/" to "/opt/teamspeak" then edited the teamspeak file so it look like...

"#!/bin/sh
#
# This starup script will set the correct library path
# and then startup the teamspeak binary.
#

export LD_LIBRARY_PATH=/opt/teamspeak:$LD_LIBRARY_PATH
/opt/teamspeak/TeamSpeak.bin $*"

Then when i try to run it i get...


"USER@COMPUTER:~$ cd /opt/teamspeak
USER@COMPUTER:/opt/teamspeak$ ./TeamSpeak
./TeamSpeak: 8: /opt/teamspeak/TeamSpeak.bin: not found
USER@COMPUTER:/opt/teamspeak$ sudo ./TeamSpeak
./TeamSpeak: 8: /opt/teamspeak/TeamSpeak.bin: not found"

At this point i would forgive you for thinking i was abit useless and was in the wrong folder or something of the like so to prove otherwise...

"USER@COMPUTER:/opt/teamspeak$ ls
clicense.txt libborqt-6.9-qt2.3.so manual TeamSpeak
client_sdk libHVDI.so.0.8.0 Readme.txt TeamSpeak~
icon.xpm libspeex.so.1.0.0 sounds TeamSpeak.bin"

I have all the correct permissions have tried all steps as "USER/ROOT/SUDO" all of which give me the same errors.
So i am completely lost, any advise would be appreciated.

ToeKing
January 5th, 2007, 05:53 AM
remove the sh. just do "sudo setup.sh"

Monkeysuit
February 10th, 2007, 12:58 PM
Maybe im just blind, but I have tried a multiple of ways and get this error.

setup.data/installer/installer: No such file or directory

I have done all the path inclusions in the script files, but no joy at all. Any ideas?

hamil
March 11th, 2007, 09:35 PM
Hello!

As the earlier poster, I am not getting there either...

Running sudo sh setup.sh gives:

setup.sh: 14: Syntax error: Bad substitution

Whereas sudo setup.sh gives:

sudo: setup.sh: command not found

Any guidance would be highly appreciated...

simplyw00x
March 11th, 2007, 10:04 PM
carl@puzzlement:~$ apt-cache policy teamspeak-client
teamspeak-client:
Installed: 2.0.32-2
Candidate: 2.0.32-2
Version table:
*** 2.0.32-2 0
500 http://gb.archive.ubuntu.com feisty/multiverse Packages
100 /var/lib/dpkg/status
carl@puzzlement:~$
It's in fiesty

hamil
March 12th, 2007, 01:31 PM
Good that it has found it's way into Feisty, but it would still be nice to know why this error occurs, and what one can do to get around that error.

Thanks for the tip, will see if I download it later.

Edit:
And for the ones who does not want to add the Feisty to their repos, this would the link for the deb file:
http://gb.archive.ubuntu.com/ubuntu/pool/multiverse/t/teamspeak-client/teamspeak-client_2.0.32-2_i386.deb
And you do get an error for missing dependencies, if you do not run Feisty (libc6)

noenter1
March 20th, 2007, 06:32 AM
The correct code would be:

sudo ./setup.sh
Hope this works for you hamil it did for me.



EDIT: Official Howto is @ https://help.ubuntu.com/community/TeamSpeak