View Full Version : Installing Lexmark X1290 printer on 64-bit Ubuntu 10.10

November 30th, 2010, 03:31 PM
I upgraded from a 32-bit Ubuntu 10.04 to a 64 bit Ubuntu 10.10.
Under 32-bit Ubuntu 10.04, I had a Lexmark X1290 printer working flawlessly. Now I'm trying to install this printer again on the 64-bit Ubuntu 10.10 system.

I'm following the instructions from http://www.trodrigues.net/wiki/linux:ubuntu:lexmark_x1290 (http://web.archive.org/web/20080119224658/http://www.trodrigues.net/wiki/linux%3aubuntu%3alexmark_x1290) and using the Z600 series driver from Lexmark.

Create a directory named lexmark and unpack the driver:

mkdir lexmark
tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz
Extract the driver from the install script:

tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz
And untar it:

tar -xvzf install.tar.gz

This generates 2 drivers (z600cups-1.0-1.i386.rpm and z600llpddk-2.0-1.i386.rpm) that then should be converted to .deb files with alien and installed with dpkg, but -as the filenames already indicate- the drivers are for 32-bit systems and not for 64-bit systems. Hence the error:

$ sudo dpkg -i z600cups_1.0-2_i386.deb
dpkg: error processing z600cups_1.0-2_i386.deb (--install):
package architecture (i386) does not match system (amd64)
Errors were encountered while processing: z600cups_1.0-2_i386.deb
Any idea how I can get this to work?

July 1st, 2011, 10:44 PM
To install the z600 driver on an amd64 or x86-64 platform see the instructions here:

You will have to download the tarball CJLZ600LE-CUPS-1.0-1.TAR.gz from an alternative location.

e.g., do,


Or if that location is now dead try one from the list here:

July 1st, 2011, 11:06 PM

After installing the z600 driver as above, I tried printing a test page and received a system tray message:

Printer "Lexmark_X1100" cups-insecure-filter.

SOLUTION: (worked for me)

sudo chown -R root:root /usr/lib/cups/filter/
sudo chown -R root:root usr/lib/cups/backend/

I'm using:
cups 1.4.6
kernel: Linux version 2.6.38-8-generic
arch: x86_64