View Full Version : [SOLVED] firefox https won't connect

November 30th, 2010, 07:41 AM
OK, this is starting to annoy me...

Ubuntu 10.10, firefox3.6.12

I can't connect to any site with https, including Add-ons. In the first case I generally get a time-out error, Add-ons gives a pretty terse "Firefox couldn't retrieve Add-ons". I guess the latter is related to the former... an https problem.

Incidentally, Chromium works just fine!

So far I have
enabled ssl v2
enabled cookies
checked settings against a 10.04/FF3.6.12 which does work
torn my hair out
rent my garment...etc

Any more ideas most welcome!


November 30th, 2010, 07:52 AM
Try this. (http://support.mozilla.com/en-US/kb/Firefox+cannot+connect+securely+because+the+SSL+pr otocol+is+disabled)

November 30th, 2010, 08:07 AM
Try this. (http://support.mozilla.com/en-US/kb/Firefox+cannot+connect+securely+because+the+SSL+pr otocol+is+disabled)

Thanks, been there but did it over in case I missed something. No Joy.

You know, I have a feeling I've been here before... can't remember what the cure was :confused:


November 30th, 2010, 08:13 AM
You should use Chrome instead. It runs a lot faster than FireFox and has addons as well.

Download----> Here (http://www.google.com/chrome)

November 30th, 2010, 12:24 PM
Swiftfox might be an alternative firefox solution.

Some solution. (https://qa.mandriva.com/show_bug.cgi?id=58654)

November 30th, 2010, 02:34 PM
Try starting firefox from a terminal and see if you can get any helpful error messages.

December 1st, 2010, 04:16 AM
Solved!!!! thanks to the folk at #ubuntu.au irc.

The problem is in with https and IPv6 :confused:

go to about:config
navigate to network.dns.disableIPv6 and set it to true (double click)

Don't ask me, but it works