PDA

View Full Version : [ubuntu] 10.10 ASUS 1215N no sound from speakers



TheLuckys
November 29th, 2010, 10:18 AM
Hi all,

I've been running Ubuntu 10.10 on my 1215N for some time now. Everything worked fine until this morning when I couldn't play any sound.
After a bit of research and searching google, I found that it's just the internal speakers that aren't working. If I plug in my headphones, I do hear music.
I tried everything in the SoundTroubleshooting help page.

The only solution to this problem I could find (specific for the 1215N) was to reinstall Ubuntu.
Is there any other solution?

mikesimmonds
December 1st, 2010, 01:54 PM
Joined forum for this post; I had same problem with my 1215n. Tried absolutely everything - was about to reinstall and remembered that last time I had watched a video in rhythmbox, I closed the lid without stopping the video...

So, I closed the lid, let the pc suspend, then opened it up again back into 10.10 and WHAM my audio is working again.

Perhaps the 1215n has trouble with suspend under ubuntu?

EDIT: I'm a noob - it would have been movie player, not rhythmbox...

natecarp
December 1st, 2010, 09:44 PM
@mikesimmons: thanks for your account. I just experienced the same fix with my ASUS 1015PE in which all I had to do was put the computer back into suspend.

TheLuckys
December 3rd, 2010, 08:23 AM
My god! You're awesome! Thanks!
I rebooted like 10 times, and it didn't do anything.
But when I closed the lid, and opened it back up, it suddenly worked!

lerwys
December 13th, 2010, 05:57 AM
Hi all,

I know that the problem has already been fixed, but I was experiencing the same problem and it got fixed just by suspending ubuntu.

Thanks

LtPitt
January 16th, 2011, 01:12 PM
God bless you: problem solved.

LtPitt
February 2nd, 2011, 10:05 PM
Not definitely :(

Random my laptop crashes (it's always sound-related... Often after entering password I get a squirky sound never stopping and mouse freezes, alt + f1 produces nothing)...
What can I do?

rawsilk
May 15th, 2011, 05:11 AM
Oh how I do thank thee! Headache gone with a simple flick of the wrist... literally.

ps Just joined the forum and running Ubuntu 11.04 on my asus 1215n. First time with single OS being linix.

fermin
July 8th, 2011, 01:04 PM
Well I magically experienced the same fix: pressed suspend, turn on again and now internal speakers work! Before I could only hear sound from the headphones jack, as others said. My laptop is an eeePC 1215P and I'm running a fresh install of Ubuntu 11.04. I hope not to have any further problems or crashes as the above user said :S But if I do I'll be sure to let you know. Thanks!

ehdis
July 19th, 2011, 09:20 AM
i'm experiencing the very same problem but i have Asus Eee PC 1005 HA and the suspend doesn't work properly... my computer is totally mute
i tried to change it with Fn buttons but the speaker icon on the panel stays grey (and shows mute), i tried to change sound preferences, nothings seems to work...

has anyone had such problem? i searched ubuntu forum for it but found nothing...

aaberr
October 11th, 2011, 04:01 PM
Any update regarding this issue? I'm having a similar problem with 1215p, any workaround better than the sleep solution?

metaloprof
January 26th, 2012, 03:23 PM
Very new to Ubuntu/Linux so apologies for adding to this post. I too have this problem with an old Toshiba Satellite P100, None of the scripts relating to sound card etc not working helped but came across this thread and hey presto closing the lid and hibernate on power management restored the audio!

Many thanks guys, I think I will enjoy being a Linux user!!