View Full Version : [ubuntu] Need Help Updating BIOS on AO532h

November 29th, 2010, 04:44 AM

I read here: https://help.ubuntu.com/community/AspireOne/532h that the BIOS is "easily" updatable with a FreeDOS USB stick. Thing is every forum, tut, or manual I follow results in failure. The USB drive never boots the screen is black and says "FreeDOS" in the upper left corner. If I do get it that far. Most of the time the 3 BIOS files that are vital to the update do not fit because every tut is for a Floppy drive. Well all 3 files are too big for that. So I am screwed in that aspect as well. I would really like step by step instructions on how to do this successfully because it fixes a major bug on this laptop. Any help is appreciated. Thanks!

November 30th, 2010, 03:11 AM
o h o
e p

Please I need help lol thanks again

November 30th, 2010, 04:22 AM
Not sure if I can help but my friends Acer Aspire one had similar problems. We had to download the program using Windows. Here's the solution we used;

1. Go to the following address- (it'll download a zip file)(the file you'll need is attached herein)


2. Unzip the file (use Windows to unzip)

3. Open the folder and copy two files to a formatted FAT
usb stick. Rename the file FLASHIT to FLASHIT.EXE and the second file
3309.fd(bios file) to ZG5IA32.FD

3. Insert the usb stick into the usb left hand side make sure the charger is plugged in.

4. Hold down keys fn+esc and power up the laptop. When the power led begins to blink release the two buttons and press the power button just once, observe the usb stick flashing indicating it's flashing the bios.
...hope that helps

November 30th, 2010, 05:22 PM
I do not have windows installed on this machine. I do however have a windows machine I can use to make the bootable drive if its easier.

November 30th, 2010, 05:29 PM
Yes, that's exactly how I did it- got the programs using Windows and installed them on a usb.

November 30th, 2010, 06:04 PM
to be sure that all should work like a charm I suggest:

1- disconnect your hard drive
2- connect a new one
3- install windows version needed by the manufacture flash utility
4- boot windows
5- flash your bios
6- disconnect the hard drive
7- connect the hard drive with ubuntu
8- enjoy

I say this cause I burn a bios with freedos tecnique, so I use this method to upgrade my bios.


November 30th, 2010, 06:30 PM
The computer we fixed was a dual boot and at no time did we use the Windows os on that machine nor could we- the bios was messed up.

Try what I suggested. I understand your frustration- all of the sites you look at show some simple solution that works for everyone...but you. That's what I thought until I tried the fix I mentioned. For whatever reason the bios reflash has worked 2 times so far or about a years period of time.

November 30th, 2010, 08:54 PM
Alright Ill give it a shot then. Do I have to rename the files? The files you renames were different names to begin with.

November 30th, 2010, 10:37 PM
CAUTION- DO NOT reflash you bios until you verify that the bios specified above is the exact one for your machine.

That said....

Rename the file FLASHIT to FLASHIT.EXE

Rename 3309.fd(bios file) to ZG5IA32.FD

Rename them precisely like that.

December 1st, 2010, 04:27 AM
Couldnt get it to work. Whomever posted that information on the laptop community docs needs to reply in here because its not as "easy" for everyone. I have tried dd tried grub tried everything.

December 1st, 2010, 04:39 AM
Have you tried Ubuntu LiveCD?

December 4th, 2010, 07:05 PM
How would an ubuntu live cd help?

December 4th, 2010, 11:11 PM
Live CD will at least get you booted into Ubuntu where you can either install it or just try it out. The foregoing assumes you BIOS is ok.

Give it a try....it'll only take a few minutes to find out if you can boot into Ubuntu.

December 5th, 2010, 04:42 PM
I stated on the first page of this thread that the laptop that needs the BIOS update is using ubuntu and ubuntu only. So a live cd is a waste of time.

December 6th, 2010, 12:06 PM
If you're so inclined I'll buy your computer from you.

Just send a PM telling how much you want for it.

December 10th, 2010, 12:01 AM
I appreciate your help but no thanks. Ill wait for a better solution.

December 11th, 2010, 01:16 PM
I created my own somewhat beat around the bush solution to the problem.

Step 1:

Back up the drive using Clonezilla Live

Step 2:

Create a bootable Windows 7 usb drive

Step 3:

Boot into Gparted Live and format drive to ntfs

Step 4:

Install Windows 7

Step 5:

Install BIOS update straight from windows

Step 6:

Boot back into Clonezilla to restore previously saved image

Step 7:

Enjoy the fix :)

December 31st, 2010, 10:17 PM
I had this problem with my AO532h a while back. Here's what worked for me (as far as I can remember):

1) Follow the instructions here (http://www.bay-wolf.com/usbmemstick.htm) to create a bootable flash drive (note: you will need to use Windows).

2) Get the latest BIOS from acer here (http://global-download.acer.com/GDFiles/BIOS/BIOS/BIOS_Acer_1.25_A_A.zip?acerid=634139072709889300&Step1=Netbook&Step2=Aspire%20One&Step3=AO532h&OS=722&LC=en&BC=Acer&SC=PA_7) (1.25 at time of writing).

3) Copy the DOS version of the update utility to the flash drive.

4) Boot your netbook from the flash drive.

5) Run the batch file provided by Acer and you're done.

This BIOS update fixed a bug where the system would randomly go into standby mode when running on battery power.