View Full Version : [ubuntu] Am I the only one who's samba doesn't work?

November 28th, 2010, 08:18 PM
I'm really getting sick of beating my head against the wall over this.
Is there some magic button I need to push to get samba to just f***ing work?! When I first switch to linux, I started using Gutsy and networking worked just fine! But pretty much ever since about 8.10 I haven't been able to get file or print sharing to work properly. I can "connect to server" and type in the ip address of another computer and access shared files but I've completely given up on sharing a printer, it just isn't going to happen.
Is there another distribution who's samba is horribly crippled?

November 29th, 2010, 12:04 AM
I'm on 10.10 and haven't gotten the help I used to get. My two Ubuntu computers cannot see one another at all. I have posted multiple requests in various forums too. I am surprised there isn't a sticky on this issue. I also feel like I can't be the only one with this problem.

November 29th, 2010, 12:13 AM
ok, samba is in a weird spot right now in the linux ecosystem, because it has always been a server technology, but now we want to integrate it into desktop systems like ubuntu.

as such, if you want to use the gui to share stuff, things work a little differently than when you are working with classic samba.

lets see where you are at. please post back the output of these commands, and a summary of what you have already done, and what you are trying to do (naming service, etc):

net usershare info
testparm -s
cat /etc/samba/smb.conf

as for printing, I am not the guy to ask. there is a lot more than just samba involved in online printing, so there is lots of room for crossvendor confusion.

November 29th, 2010, 01:00 AM
this is how i set mine up, but doesn't work:


November 29th, 2010, 01:27 AM
this is how i set mine up, but doesn't work:

it looks like it doesn;t think samba is installed. did you get anything from testparm -s?

November 29th, 2010, 02:27 AM
yes, and I think mine is solved, but helen went to bed so I can't check it further. i can see her and get in as well, she can see mine, but can't get in-so I think it means to give it a few more minutes, but thats tomorrow...

The problem seems to have been that when I installed them, I gave them both the same host name. I found a good link on how to change that:

so the things is is that ubuntu to ubuntu doesn't use samba, it uses nfs but still gets listed under a windows network for some reason...

November 29th, 2010, 03:53 PM
Resolved, finally. Hope the other thread can help you, it's here: