PDA

View Full Version : [ubuntu] 10.10 WiFi on Atheros 5212 don't work



scaper
November 27th, 2010, 11:00 PM
Hello.
I have small problem.
In my laptop, after upgrade, wifi stop working.

My laptop is Fujitsu-Siemens Amilo Pro V2065, wifi cart Philips 12127e (from IBM T41), linux kernel: 2.6.37-020637rc3.
This card worked before upgrade, and work on windows.

Command lshw -c network return:

*-network:0 UNCLAIMED
description: Ethernet controller
product: AR5212 802.11abg NIC
vendor: Atheros Communications Inc.
physical id: 5
bus info: pci@0000:06:05.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: pm cap_list
configuration: latency=80 maxlatency=28 mingnt=10
resources: memory:b8000000-b800ffff
Command lspci return:

06:05.0 Ethernet controller [0200]: Atheros Communications Inc. AR5212 802.11abg NIC [168c:1014] (rev 01)

Why is unclaimed?

I install MadWifi drivers, but don't work, and i try ndiswrapper but return error

Module could not be loaded. Error was:

WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
FATAL: Module ndiswrapper not found.Please help me, wired laptop is desktop :(

scaper
November 28th, 2010, 11:32 AM
Please help with it.

MooPi
November 28th, 2010, 04:21 PM
Try a couple of commands from terminal
lspci>pci.txt
iwconfig>wconfig.txt
lsmod>mods.txt
This will drop three files pci.txt, wconfig.txt, mods.txt in your home folder. Attach to the next message for us to review.

scaper
December 12th, 2010, 12:53 PM
Sorry from time.
I atteched this 2 files, because result of iwconfig>wconfig.txt is empty

MuppetandChums
January 15th, 2011, 04:38 PM
did this get anywhere ?

I'm in the same boat.

T41
10.10
Atheros AR5212

No wireless ( worked fine before OS upgrade)

Wired OK.

(& this is 2011 & I know this isn't Wizard land...but ye gods...i thought i had left this level of interoperability & kludge behind in the 1990s)

Now where's that Macbook ?

Muppet & Chums