PDA

View Full Version : [SOLVED] Epsxe No Sound On Ubuntu 10.10



axelord
November 22nd, 2010, 04:12 PM
Dear friends at Ubuntu Forum,

I`m getting no sound from Epsxe on Maverik, seems to be a problem with the SPU Plugin (as it seems its not kicking in when lauching the game). All my plugins are latest version and were working just fine on 10.04. Has anyone figured that out already? any help is more than welcome!

P.S: Games are emulating just fine, only sound isnt working. Also, tried to compile the OSS sound plugin for ALSA but returns an error regardind a wrong pentium -m parameter...(my processor is a AMD PhenonII x4 965) :-(

Darent
December 14th, 2010, 01:25 PM
Same problem here... don't mess with the plugins because it's not the reason, if you look the terminal output say something about "not loading libcanberra-gtk-module.so" so its a problem related with the sound libraries of the system, not the emulator. Reinstalling libcanberra doesn't solve it.

The only solution i've found is running the epsxe 1.7 for windows under wine, it works well, but my system is not enough powerfull to run it smooth (ubuntu emulating windows emulating a psx...), but give it a try.

If you found a solutions, please post it here :) Good luck!

WINGZERO619
December 17th, 2010, 05:05 AM
I'm currently running ePSXe 1.6.0 using WINE. Graphics and sound currently work without issue. For my sound plugin, I am using the Eternal SPU Plugin 1.41. It's pretty much in the default setting with the exception of checking off one more option, "Enable XA sound (Select to enable XA sound in MDEC). I am running all this on an Acer Aspire Timeline X 1830T-68U118. Hope the sound plugin info helps.

Buttink
December 17th, 2010, 06:32 AM
have you tried


padsp ./epsxe

Assuming you have an OSS plugin.

dmatos88
December 19th, 2010, 06:39 PM
have you tried


padsp ./epsxeAssuming you have an OSS plugin.

It really fix the no sound problem, thanks.

Darent
December 19th, 2010, 10:14 PM
Hi, thanks a lot! it worked for me too. The sound is working, except for the cdda (no soundtrack in wip3out for example), but i think that's a diferent problem.

Funny but the 1.7 running under wine works better than the 1.6 linux...

axelord
March 19th, 2011, 08:49 PM
It indeed solves the problem. Thanks guys.

z-itou16
April 23rd, 2011, 06:52 PM
Buttink,

THANK YOU SO MUCH! Can you imagine I even tried to compile using ALSA and it worked but not fluently.

Using wrapper was brilliant and truly helpful.

Many thanks

Je Et
May 29th, 2011, 04:54 AM
have you tried


padsp ./epsxeAssuming you have an OSS plugin.


Had been trying everything to get the sound to work and padsp ./epsxe worked like a charm. Exactly what does that do? Again... many thanks!

moebius444
June 6th, 2011, 09:06 AM
padsp ./epsxe


i confirm that this works in kubuntu 11.04

adrianj2012
July 20th, 2011, 12:10 AM
I hope I'm posting in the right place (still somewhat new), but whenever I try the command

padsp ./epsxeI get this:

exec: 88: ./epsxe: Permission deniedRunning with sudo before it makes no difference.
Any thoughts? If it helps, the sound plugin I'm using is P.E.Op.S. OSS Audio Driver 1.9
Thanks in advance!

Darent
July 20th, 2011, 09:18 AM
Probably epsxe is not marked as executable, in the directory where epsxe is, run:

chmod +x epsxe

(you'll need sudo only if epsxe is installed system-wide, not if it's in your home)

After that, you should be able to run it with your command:

padsp ./epsxe
Usually in linux when you download an executable the system doesn't trust it and doesn't allow it to run until you change its permissions with chmod +x

Good luck!

adrianj2012
July 24th, 2011, 05:16 AM
Thanks, Darent! Changing the permissions did the trick! Now to tweak the sound plugin to get it exactly how I want it... thanks again, everyone!

Possum93
March 14th, 2012, 07:34 PM
No Sound!


I have just installed Ubuntu 10.10 on a multi-boot system and my sound card doesn't even show up. There is sound on the other operating systems, but not on Ubuntu 10.10. I have an Realtek ALC260 sound card not sure what to try next any suggestions, thought about reinstalling because prior to updates it worked.

hackedhacker
February 24th, 2013, 09:23 AM
have you tried


padsp ./epsxeAssuming you have an OSS plugin.
This solved mine...
thanks...