View Full Version : apt-get interrupted

February 20th, 2005, 01:10 PM

I interrupted (Ctrl-C) apt-get while it was downloading java1.5 and since then, when I run apt-get it says:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

After I do what it says, apt-get seems to work until I reboot my computer. Then problem returns again. Is there a way to fix this?


February 20th, 2005, 01:18 PM
sudo apt-get -f install

February 20th, 2005, 01:33 PM
This is a desperate call for help. Sorry to bug you.....HOW do I post a message on this forum. I am completely new to this. There is no "post new message" or anything like it. I am logged on but this forum tells me nothing.

February 20th, 2005, 01:46 PM
sudo apt-get -f install

$ sudo apt-get -f install
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

@Kujane: At the forum-index page of each subforum there is a "New Thread"-link.

July 1st, 2006, 12:12 PM

sudo dpkg --configure -a

July 6th, 2006, 03:38 AM
February 20th, 2005


August 27th, 2006, 03:32 PM
Sorry to resurrect and old thread, but I'm having this problem too. I've tried following the method above, but the problem is that when I do so, the process (I'm trying to install the MS core fonts) connects to an incredibly slow server, and the install process gives up on some or all of the packages because they're so slow to download. I eventually kill the process by closing terminal. How can I get rid of this, so that I don't keep getting bugged by it? I'm not bothered about installing the fonts.

May 28th, 2007, 05:16 AM
try this try sudo dpkg --configure -a && sudo apt-get -f install

i am sure it will work