PDA

View Full Version : [PPC] 10.10 Maverick, PowerBook G4 15" Touchpad jumpy/useless



crayzeigh
November 14th, 2010, 04:28 AM
I apologise in advance if this topic has already been talked about but I could not find my specific issue anywhere, so I thought I would start a new post after searching for days for the answer.

I installed Ubuntu 10.10 on my PowerBook G4 (I think that's powerbook 5,6 but I could be mistaken). Most everything is fine from a function standpoint except for the touchpad/trackpad. Unlike most users who seem to be getting an insensitive touchpad, mine seems to be picking up some interference from an unknown source. The mouse frequently jumps around the screen either horizontally back and forth or sometimes vertically. If I disable the trackpad it seems to stop (at least for a few minutes). Sometimes I can lay my palm flat on the trackpad and it will cause the mouse to stand still also which makes the external mouse usable.

Are there any solutions to this? (I did install the, what is it, gpointing-devices package? The one that provides the GUI for touchpad configuration and that has not helped at all, except that I can use it to periodically disable the trackpad for a temporary fix)

Sorry my post could not be more exact I don't have access to that computer at the moment and this issue had been bothering me enough that I needed to post. Let me know if any more info is needed and I'll get it.

Thanks

itismike
November 14th, 2010, 06:53 AM
did you check your model here? https://wiki.ubuntu.com/MactelSupportTeam/CommunityHelpPages

Sounds like this known issue: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/27541

crayzeigh
November 14th, 2010, 03:10 PM
It is not the same as that issue, it has no baring on whether or not keys are pressed. I cannot use the touchpad as normal it won't respond to my touch in normal ways. When I am pressing nothing at all on the keyboard the mouse will bounce around (usually along the X or Y axis only at a time) unless I turn off the touchpad (which solves this usually only for a couple of minutes then it starts happening again, which can allow me to turn off the touchpad again using gpointing devices. I haven't entirely disabled the touchpad since I'd like to try to get it working).

Also it's not a Macintel, it's a PowerBook, hence the "PPC" prefix.

itismike
November 14th, 2010, 03:20 PM
Sounds like very peculiar behavior. Is it possible it is a hardware issue? Do you still have a Mac OS installation, and if so, does it act normal in that setting? Sorry I don't have much exposure to PPC so my knowledge of this issue is limited.

crayzeigh
November 14th, 2010, 05:36 PM
Peculiar, definitely. I thought about a hardware issue at first but I just switched from OSX10.4 where I had no issue at all and had Yellow Dog Linux installed for a while also with no issues. This issue only appeared in Maverick. I'm thinking of trying some older versions of Ubuntu to see if it's something with the new way that Ubuntu handles X.

grey.skylark
November 15th, 2010, 08:50 PM
I have encountered the same issue with 10.10 on my Powerbook G4 12". I got around it by using a mouse. both my old wired mouse and my girlfriend's wireless Logitech mouse worked immediately and have not displayed the same jumpiness.

I know this isn't a perfect solution, but it might be a useful stopgap if nothing else.

Best of luck!

Alektrotsky
November 22nd, 2010, 10:14 PM
I have the exact same problem with my Powerbook G4. Ever since I upgraded to 10.10, the touchpad has become useless. And for some reason, when I plug a usb mouse in, the right click and left click buttons essentially switch places.

gbsrd
November 24th, 2010, 11:52 PM
I think I'm having the same issue. I'm running 10.10 on a powerpc G4. On occasion, the responsiveness of the cursor will freeze up. It'll be very jumpy vertically, and very difficult to move horizontally, weighted in a single direction along that axis.

So, it'll be going all over the place up and down at the slightest touch, and will want to move to the left more than right, but both left and right take some valiant dragging. Also, the single button will behave like a right click rather than a left.

Like I said, this is an intermittent problem; sometimes the touchpad works fine. The freeze has happened whilst on the login screen and after login has already occurred.

I'm dual booting OS X 10.4, and there's no problem at all on that partition.

cpu_medic
November 25th, 2010, 07:21 PM
I'm going to BUMP this, because I am having the same problem

KiLaHuRtZ
November 27th, 2010, 08:04 AM
I also was plagued by this issue. I just got done installing Maverick on my iBook G4 about 1.5 hours ago and have been messing with this since.

I am happy to report that I crafted a possible workaround after "Google'ing" around a bit.

I took the settings from the kernel module (appletouch) maintainer here (http://www.popies.net/atp/index.html) and setup X to use them.

It's not 100% but it's a 95% improvement versus what it was.

This is what I did.


sudo mv /usr/share/X11/xorg.conf.d /usr/share/X11/xorg.conf.d.bak

sudo mkdir /usr/share/X11/xorg.conf.d

sudo cp /usr/share/X11/xorg.conf.d.bak/10-evdev.conf /usr/share/X11/xorg.conf.d/.

sudo vi /usr/share/X11/xorg.conf.d/50-appletouch.conf

Add the config to this file and save; or download it from me here (http://www.digitalenigma.net/~luke/ubuntu/maverick/appletouch-fix/50-appletouch.conf).


Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "LeftEdge" "0"
Option "RightEdge" "850"
Option "TopEdge" "0"
Option "BottomEdge" "645"
Option "MinSpeed" "0.4"
Option "MaxSpeed" "1"
Option "AccelFactor" "0.02"
Option "FingerLow" "55"
Option "FingerHigh" "60"
Option "MaxTapMove" "20"
Option "MaxTapTime" "100"
Option "HorizScrollDelta" "0"
Option "VertScrollDelta" "30"
Option "SHMConfig" "on"
EndSection

Now you should have a file tree like this.


/usr/share/X11/xorg.conf.d
├── 10-evdev.conf
└── 50-appletouch.conf
/usr/share/X11/xorg.conf.d.bak
├── 10-evdev.conf
├── 50-synaptics.conf
├── 50-wacom.conf
├── 51-synaptics-quirks.conf
└── 60-magictrackpad.conf

Now restart GDM.


sudo /etc/init.d/gdm restart

And change your mouse settings like this; or whatever works best for you.

http://www.digitalenigma.net/~luke/ubuntu/maverick/appletouch-fix/mouse-settings.png

Hope this helps you guys out...

Oh, and make sure you are using kernel train version 2.6.35-23...

drkages
December 21st, 2010, 07:02 PM
I have been searching for a while, but I am having a lot of difficulties with these tutorials.

Most tutorial specify to change the xorg.conf file in the /etc/X11 folder. However I have no file by that name in the folder.

I fould that xorg has config files in /usr/shar/X11/xorg.conf.d/

I tried "X --configure" but it creates a file "xorg.conf.new" in my home directory and then it fails to boot back into gdm

I have the same problem with the track-pad and my video(hardware acceleration).
I am using the Powerbook G4 17 (not sure anymore specs than that)

Need help

linuxopjemac
December 21st, 2010, 08:53 PM
Can you try to give a link to your PowerBook in everymac.com ?

drkages
December 21st, 2010, 09:58 PM
Can you try to give a link to your PowerBook in everymac.com ?


http://www.everymac.com/systems/apple/powerbook_g4/stats/powerbook_g4_1.67_17.html

linuxopjemac
December 21st, 2010, 11:08 PM
You might want to start here:
http://mac.linux.be/content/xorgconf-ppc-machines-radeon-9600-and-kms-kernel-lucid-lynx

drkages
December 21st, 2010, 11:23 PM
You might want to start here:
http://mac.linux.be/content/xorgconf-ppc-machines-radeon-9600-and-kms-kernel-lucid-lynx

I tried the link before, but in good spirit I did it again AND IT WORKED!!!

The only thing I did differently was comment out the Device ID

Thanks a lot

linuxopjemac
December 22nd, 2010, 11:40 AM
You are welcome. Enjoy your good old PowerBook.