View Full Version : [ubuntu] HP Pavillion dv2745se

November 4th, 2010, 06:23 PM
I have an HP Pavillion dv2745se and I cannot get the wifi adapter to work.

Here are the data points as per the network issue instructions:


04:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

~$ iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11 Access Point: Not-Associated

Link Quality:5 Signal level:0 Noise level:0

Rx invalid nwid:0 invalid crypt:0 invalid misc:0


~$ lsmod

Module Size Used by

parport_pc 26058 0

ppdev 5556 0

binfmt_misc 6599 1

snd_hda_codec_conexant 29736 1

joydev 8735 0

nouveau 516971 2

snd_hda_intel 22107 2

snd_hda_codec 87552 2 snd_hda_codec_conexant,snd_hda_intel

snd_hwdep 5040 1 snd_hda_codec

snd_pcm 71475 2 snd_hda_intel,snd_hda_codec

ttm 56633 1 nouveau

drm_kms_helper 30200 1 nouveau

snd_seq_midi 4588 0

snd_rawmidi 17783 1 snd_seq_midi

lib80211_crypt_tkip 7736 0

snd_seq_midi_event 6047 1 snd_seq_midi

snd_seq 47174 2 snd_seq_midi,snd_seq_midi_event

drm 168054 4 nouveau,ttm,drm_kms_helper

snd_timer 19067 2 snd_pcm,snd_seq

r852 9536 0

sm_common 3285 1 r852

snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq

hp_wmi 5191 0

uvcvideo 55847 0

nand 34905 2 r852,sm_common

wl 1959533 0

videodev 43098 1 uvcvideo

v4l1_compat 13359 2 uvcvideo,videodev

snd 49006 13 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec ,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,s nd_seq_device

nand_ids 2903 1 nand

nand_ecc 3938 1 nand

mtd 18877 2 sm_common,nand

psmouse 59033 0

agpgart 32011 2 ttm,drm

soundcore 880 1 snd

lib80211 5058 2 lib80211_crypt_tkip,wl

serio_raw 4022 0

i2c_algo_bit 5168 1 nouveau

k8temp 3132 0

snd_page_alloc 7120 2 snd_hda_intel,snd_pcm

i2c_nforce2 5179 0

video 18712 0

output 1883 1 video

lp 7342 0

parport 31492 3 parport_pc,ppdev,lp

firewire_ohci 21106 0

firewire_core 46643 1 firewire_ohci

sdhci_pci 6339 0

sdhci 15890 1 sdhci_pci

crc_itu_t 1383 1 firewire_core

led_class 2633 1 sdhci

forcedeth 49433 0

ahci 19013 0

libahci 21667 3 ahci

pata_amd 8746 0


This command did not return any data.


~$ sudo lshw -C network


description: Ethernet interface

product: MCP67 Ethernet

vendor: nVidia Corporation

physical id: a

bus info: pci@0000:00:0a.0

logical name: eth0

version: a2

serial: 00:1d:72:46:0a:a7

capacity: 100MB/s

width: 32 bits

clock: 66MHz

capabilities: pm msi ht bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation

configuration: autonegotiation=on broadcast=yes driver=forcedeth driverversion=0.64 latency=0 link=no maxlatency=20 mingnt=1 multicast=yes port=MII

resources: irq:42 memory:fc488000-fc488fff ioport:30f8(size=8) memory:fc489c00-fc489cff memory:fc489800-fc48980f

*-network DISABLED

description: Wireless interface

product: BCM4312 802.11b/g LP-PHY

vendor: Broadcom Corporation

physical id: 0

bus info: pci@0000:04:00.0

logical name: eth1

version: 01

serial: 00:1a:73:e6:1a:2f

width: 64 bits

clock: 33MHz

capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless

configuration: broadcast=yes driver=wl0 driverversion= latency=0 multicast=yes wireless=IEEE 802.11bg

resources: irq:21 memory:fc000000-fc003fff

~$ iwlist scan

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Interface doesn't support scanning.


~$ lsb_release -d

Description: Ubuntu 10.10


~$ uname -mr

2.6.35-22-generic i686


~$ sudo /etc/init.d/networking restart

[sudo] password for dave:

* Reconfiguring network interfaces... [ OK ]

Help! I installed Ubuntu 10.10 because I am an audiophile and the output to USB via livesession rhythmbox was noticeably better than Windows Vista using Foobar even with the Kernel streaming plugin enabled. But I cannot get the wifi adapter to work, and so I cannot really use Ubuntu.

The live session activated the Broadcom STA driver, but said it needed to restart to use it. I figured ok, let's install Ubuntu onto my hard drive and then the driver will work because a restart would accept config changes.

I installed it and now the "Additional Drivers" window comes up blank!


November 4th, 2010, 07:24 PM
You need to activate the Broadcom STA driver. You will need a network connection other than the wireless. You should have seen a warning about haing a network connection during the install.

November 4th, 2010, 07:47 PM
Okay, that's fine, it said that it was recommended . . . anyway, that is not an option for me.

How are you supposed to have an internet connection when no ethernet connections are available and your wifi driver isn't working?

Is there any other solution?

November 4th, 2010, 08:46 PM
Okay, that's fine, it said that it was recommended . . . anyway, that is not an option for me.

How are you supposed to have an internet connection when no ethernet connections are available and your wifi driver isn't working?

Is there any other solution?

Look in the section labeled "sta -no internet access"


November 7th, 2010, 12:42 AM
I have tried everything listed, exactly following the steps, step-by-step, and still get nothing.

My install will not recognize anything.

No STA driver, no nVidia drivers . . .

The Live Session CD (but not when booted via USB) would activate the wifi driver, but it claimed it needed to restart, which a live session can never do--if I understand correctly.

So far I can't do any of the things I wanted to do with Ubuntu. No Apple Lossless support, I can't play any mpeg or avi files, . . . and none of the drivers for anything work.

November 7th, 2010, 01:22 AM
No, it is just saying that the drivers can be installed from the live CD, not to run from it. Bring it up normally and

" Systems installed from CDROM can simply add the install CD as a package source and install bcmwl-kernel-source, automatically installing the required dependencies. " Go to System>>administration>> software sources and put a check mark in "installable from CD Rom" and " and install bcmwl-kernel-source, automatically installing the required dependencies ".