View Full Version : [kubuntu] ./configure fails but missing library is not missing

November 4th, 2010, 03:06 PM

I'm trying to install gazebo but I would like the general solution please.
When I type "./configure" I get the error:

"could not find gdal_priv.h"
or sometimes
"could not find gdal library"

But I have it on my computer. It is:

This means configure is not looking in the right place for this library.
Where is the path stored, please? I tried reading the configure file but I could not find it. I tried to replace all instances of gdal_priv.h by gdal/gdal_priv.h but this did not work either.

I tried adding /usr/include/gdal to all the env PATH_something_or_other I could see.

Please tell me how to tell to ./configure where to look for libraries. What file(s) should I edit? (I tried config.status, because it contains /usr/include stuff). The files I have are:

acinclude.m4 config.h.in configure~ examples libgazebo missing server
aclocal.m4 config.log configure.in gazebo.pc libtool mkinstalldirs stamp-h1
AUTHORS config.status configure.in~ gazebo.pc.in ltmain.sh NEWS TODO
ChangeLog config.status~ configure.save gui Makefile player utils
config.guess config.sub COPYING INSTALL Makefile.am README worlds
config.h configure depcomp install-sh Makefile.in replace

Please DO NOT point me to gazebo-specific help as this is a general problem, other installs can fail in the same way. Please do not tell me "try using this-or-that instead of gazebo". Loads of such answers bloat the web and prevented me from finding the general solution.


November 4th, 2010, 04:30 PM
You try:

sudo apt-get install gdal-bin

November 10th, 2010, 09:23 PM
It says "gdal-bin is already the newest version"