PDA

View Full Version : [SOLVED] Wireless is too slow on my Ubuntu 10.10



eluis.c
November 1st, 2010, 03:41 AM
I almost can't open pages and the download is around 300B/s most of the time!!!

Any help here?

eluis.c
November 1st, 2010, 03:43 AM
And im disconnecting from the internet very often.

vsh3r
November 1st, 2010, 04:23 AM
What type of wireless card and drivers are you using? Have you tried updating your system with the drivers from the manufacture?

V$H.

eluis.c
November 2nd, 2010, 01:55 AM
Right now its a lot better, thank you for ur time!!!

Winston888
December 12th, 2010, 09:42 AM
I think this ****ing thread should be removed as it serves no purpose other than coming up top of the google search for nothing.

togume
December 13th, 2010, 01:17 AM
Please do not mark this thread as "Solved", since nothing was solved herein...

pmibal
December 16th, 2010, 06:52 PM
I was having the same issue with my Thinkpad T61 and finally fixed the problem.

My card: Intel Pro/Wireless 4965agn (iwlagn driver) which was installed by default with ubuntu 10.10 (it's correct).

However, it's also the same driver for the intel 5300. That being said, it looks like there was a config file left behind that disables the wireless N access for the 5300. I believe this file messes with anyones cards...

Solution:

Remove the following file: /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf

This fixed the issue for me. I am now back to 10mb/s DL compared to 0.6mb/s with the file.

Oh, and yes my router has wpa & wpa2 security on.

Hope this helps

teddfox
December 25th, 2010, 11:10 PM
I was having the same issue with my Thinkpad T61 and finally fixed the problem.

My card: Intel Pro/Wireless 4965agn (iwlagn driver) which was installed by default with ubuntu 10.10 (it's correct).

However, it's also the same driver for the intel 5300. That being said, it looks like there was a config file left behind that disables the wireless N access for the 5300. I believe this file messes with anyones cards...

Solution:

Remove the following file: /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf

This fixed the issue for me. I am now back to 10mb/s DL compared to 0.6mb/s with the file.

Oh, and yes my router has wpa & wpa2 security on.

Hope this helps

Worked for me on an HP 5103 THANKS!!!

Yuk-Monkey
January 2nd, 2011, 05:26 AM
I was having the same issue with my Thinkpad T61 and finally fixed the problem.

My card: Intel Pro/Wireless 4965agn (iwlagn driver) which was installed by default with ubuntu 10.10 (it's correct).

However, it's also the same driver for the intel 5300. That being said, it looks like there was a config file left behind that disables the wireless N access for the 5300. I believe this file messes with anyones cards...

Solution:

Remove the following file: /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf

This fixed the issue for me. I am now back to 10mb/s DL compared to 0.6mb/s with the file.

Oh, and yes my router has wpa & wpa2 security on.

Hope this helps

I have an Intel 4965AGN and this fixed the issue for me in. I'm running Ubuntu 10.10 on a Inspiron 1501.

open a terminal and type:

"gksudo nautilus"

and scroll to directory mentioned above and delete the file.

blujay
January 5th, 2011, 02:24 AM
Better to edit the file and change "=1" to "=0" so that a future upgrade won't just put the file back and disable N again.


sed -i 's/11n_disable=1/11n_disable=0/' /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf

Or at least add ".bak" to the filename so it will still be there if you need to disable it again. Deleting configuration files is rarely a good idea.

teddfox
February 23rd, 2011, 07:23 AM
Still, my wireless takes over 60 seconds to associate and then I have to restart it on occasion.

bd83862
February 23rd, 2011, 07:52 PM
Thanks a lot. It solved my problem too. But what does this conf file means? What it did to slow and sometimes disconnect my net?

AlanR8
February 24th, 2011, 10:23 PM
Was an interesting thread!

I have a Compaq Mini with the Intel chipset and a Sony Vaio that does not. If I load 10.10 on either machine, wireless/network becomes almost unusable. Downgrade to 10.04 and all is well.

Hmmmm