PDA

View Full Version : No Sound in Spotify with WINE



achookang
October 31st, 2010, 04:21 PM
Spotify has suddenly stopped working for me. It used to work fine about a month ago. The only recent change is that I have upgraded Ubuntu to 10.10 (previously I had 10.04) I don't think (AFAIK) that I changed the version of WINE (1.2) or Spotify Windows client.

Now when I try to play a song on Spotify I get the error "There is a problem with your sound card. Spotify can't play music"

If I open the WINE config and play the "test sound" on the Audio tab I get "Audio test failed!" It doesn't matter which driver I choose (OSS/ALSA etc or what settings for Direct Sound I try I always get the Fail message.

Any help would be greatly appreciated.

Hardware: Acer Aspire 1363 laptop, Sempron AMD processor, 0.5GB RAM, 60GB HDD
OS: Ubuntu 10.10
WINE versions: Originally 1.2 also tried upgrading to 1.3.6 developer version
Spotify version: 0.4.8.242

Refalm
November 2nd, 2010, 11:35 AM
Not a direct solution to your problem, but if you have Spotify Premium or Unlimited, you can use the Linux client:

https://www.spotify.com/en/download/previews/

On Wine:
Try setting the hardware acceleration from "Full" to "Emulate" in the sound options.

achookang
November 2nd, 2010, 02:20 PM
Thanks Refalm,

Unfortunately (or fortunately depending how you see it) I have Spotify Free, so I think the native linux client is not available for that type of account. I've also tried all the various permutations of the settings for hardware acceleration, to no avail....


thanks anyway

jimothy
December 21st, 2010, 09:36 PM
go into the wine config panel (winecfg in terminal) , go to the audio tab and change sound to alsa only,,, untick anything else, ok or apply . close spotify and reopen.

Should be fine now..

achookang
December 21st, 2010, 10:34 PM
Hi Jimothy

Thanks for the suggestions, but doing that (or any other option in the audio tab of Wine Config) still give an error.

I'm sure it is something to do with the latest version of Ubuntu as it worked fine when I was on the previous verisons (Koala or Lynx)

Spyderkid
December 23rd, 2010, 05:04 PM
You need to go into

Wine > Wine configuration > Audio THEN...

> Tick the ALSA driver
> choose Emulation on Hardware Acceleration
> Make the default sample rate 44100 (IF IT ISN'T ALREADY)
> Make the default bits per sample 16 (IF IT ISN'T ALREADY)

And then try again.
if it doesn't work then you will have to un-install and install again

_________________

And hey presto your dreams come true!

achookang
December 23rd, 2010, 10:14 PM
Thanks Spyderkid and others.

I am almost cerain that I had already tried these suggestions, but I did them again and it is working now. Maybe upgrades to Ubuntu in the meantime>

Anyway, I now can use Spotify again :)


Thanks :p

msbealo
February 7th, 2011, 09:54 PM
I had the same problem and solved it thanks.

I uninstalled wine because starting Spotify was really slow and taking more than 30 seconds/a minute to get going.

I deleted the .wine directory, reinstalled wine and then install Spotify.

Before installing Spotify the sound test worked fine, after the installation there was no sound.

I uninstalled Spotify and did various combinations before realising that if you choose the right sound driver and then CLOSE the configuration window (not just click apply) then when you reopen it the sound test works.

Once this works you can play cool music on Spotify.

Mark

P.S. This solved the slow loading problem.

Photodeus
March 22nd, 2011, 06:04 PM
Spotify has suddenly stopped working for me. It used to work fine about a month ago. The only recent change is that I have upgraded Ubuntu to 10.10 (previously I had 10.04) I don't think (AFAIK) that I changed the version of WINE (1.2) or Spotify Windows client.

Now when I try to play a song on Spotify I get the error "There is a problem with your sound card. Spotify can't play music"

If I open the WINE config and play the "test sound" on the Audio tab I get "Audio test failed!" It doesn't matter which driver I choose (OSS/ALSA etc or what settings for Direct Sound I try I always get the Fail message.


I tried reloading my alsa audio drivers....

# alsa reload
/sbin/alsa: Warning: Processes using sound devices: 3311(pulseaudio).


# (sudo) alsa force-reload

This did the trick and Spotify plays audio again on Ubuntu 10.10 for me.

stephenhau
June 3rd, 2011, 06:54 PM
Thanks, changing to 'emulation' as you suggested fixed it for me :)


You need to go into

Wine > Wine configuration > Audio THEN...

> Tick the ALSA driver
> choose Emulation on Hardware Acceleration
> Make the default sample rate 44100 (IF IT ISN'T ALREADY)
> Make the default bits per sample 16 (IF IT ISN'T ALREADY)

And then try again.
if it doesn't work then you will have to un-install and install again

_________________

And hey presto your dreams come true!

fgmart
July 23rd, 2011, 03:17 PM
Hey all,

I was getting the same "Audio test failed!" alert from the Sound configuration, regardless of which driver I tried.

I solved it by removing my .wine subdir. Then the audio test worked.

Then I reinstalled Spotify and everything's fine!

I'm using the ALSA driver, with Emulation, 44100 sample rate, and 16 bits per sample.

Bromden
October 12th, 2011, 01:39 AM
Hey all,

I was getting the same "Audio test failed!" alert from the Sound configuration, regardless of which driver I tried.

I solved it by removing my .wine subdir. Then the audio test worked.

Then I reinstalled Spotify and everything's fine!

I'm using the ALSA driver, with Emulation, 44100 sample rate, and 16 bits per sample.
Thank you i solved my audio problem too with this solution. You just had to delete the user.reg file. :)

keyshawn
October 18th, 2011, 11:26 PM
I tried reloading my alsa audio drivers....

# alsa reload /sbin/alsa: Warning: Processes using sound devices: 3311(pulseaudio).


# (sudo) alsa force-reloadThis did the trick and Spotify plays audio again on Ubuntu 10.10 for me.

This also ended up working for me on 11.04, thanks !:popcorn:

gengoro
November 26th, 2011, 03:12 AM
Switching from Full to Emulation worked for me (10.04). Thanks all for the suggestions.