PDA

View Full Version : [ubuntu] bitchX



thinkLinuX
October 30th, 2010, 02:45 PM
Hi i need help installing the bitchx in ubuntu. i download it from bitchx.org and compile it. But it can compile cause it has error. I try the sudo apt something, it also didnt work. any advise?

Rubi1200
October 30th, 2010, 03:18 PM
Did you install it using these instructions?:

How to install BitchX?

$ wget www.bitchx.com/download/ircii-pana-1.1-final.tar.gz (http://www.bitchx.com/download/ircii-pana-1.1-final.tar.gz)
$ tar xvfz ircii-pana-1.1-final.tar.gz
$ cd BitchX
$ ./configure
$ gmake
$ gmake install_localhttp://www.bitchx.com/faq.php

Also, make sure you put it in a directory that is convenient for you. By default, downloads will probably be in the Downloads folder.


But it can compile cause it has errorPost the error message please.

CharlesA
October 30th, 2010, 03:23 PM
There is also a cli IRC client called pork in the repos.

thinkLinuX
October 30th, 2010, 03:53 PM
onfigure: WARNING: cannot find setupterm - trying tgetent
checking for tgetent in -ltermlib... no
checking for tgetent in -ltermcap... no
checking for tgetent in -lcurses... no
configure: error: cannot find setupterm or tgetent

Rubi1200
October 30th, 2010, 04:02 PM
Do you have the build-essential package installed?

Check that first and then try again.

thinkLinuX
October 30th, 2010, 04:07 PM
yup i did that already, thats the outcome

Rubi1200
October 30th, 2010, 04:25 PM
Okay, next:
install the following package:
ncurses-term

You might also want to check if you have libterm-query-perl and libncurses5-dev installed too.

By they way, this seems like an awful lot of work when you could just install Pork, as suggested above by CharlesA.