View Full Version : [SOLVED] Wireless disabled on Toshiba NB 255 after installing Ubuntu 10.04 netbook addition

October 30th, 2010, 11:40 AM
Last night I installed the netbook addition of Ubuntu 10.04. The installation went fine and the netbook boots quickly, but the wireless adapter is disabled and I do not have the option to enable wireless. I also use a USB wireless device. The device when plugged in is detected but I do not have the option to enable that device either. I have been runing Ubuntu at home on me Desktop and server for over 8 months not but this is my first netbook install. I have been searching for drivers online and other possible solutions but I have yet to find a resolution. At this point I will try anything.

Bryan Sailer
Ubuntu 10.04
Toshiba netbook NB 255

December 30th, 2010, 10:20 AM
When I run the command ifconfig I get the following:
eth0 Link encap:Ethernet HWaddr 88:ae:1d:42:2a:0c
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:27 Base address:0xa000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:156 errors:0 dropped:0 overruns:0 frame:0
TX packets:156 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12160 (12.1 KB) TX bytes:12160 (12.1 KB)

and the iwconfig command shows:

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"on/any"
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on

I was able to get the Mode to be managed by modifying the /etc/NetworkManager/nm-system-settings.conf and the /var/lib/NetworkManager/NetworkManager.state. But the Wireless network still shows disabled. Does anyone know what my next step should be to turn my wireless back on.

January 5th, 2011, 12:48 PM
The simple solution was to borrow a hard drive with windows installed and turn the wifi back on. Then I replaced the hard drive with Ubuntu linux istalled and the wifi was now enabled on the laptop. Lesson learned is to ensure that you have everything turned on or the new OS will not recognize the device.