View Full Version : [lubuntu] macbook pro7,1 - touchpad

October 29th, 2010, 09:51 AM

just curious if anyone can recommend any tips for dealing with this "advanced" touchpad. I find it so frustrating, I have googled back and forth, tried a different driver or two, different settings..

But, this touchpad is barely useable. I mean, i am thinking of disabling it, because it always messes up my typing, deletes code I am writing, moves me around - where I don't want to be.

I have clicked - disable while typing, but it still hops me around.

The touchpad is too big, and too sensitive.

Can anyone recommend anything?

I love ubuntu, and use it on my desktop, no problems. but on my new laptop it is barely useable because of this simple reason.


October 29th, 2010, 01:22 PM
Have you read through this thread re: the newer multitouch drivers available in the mactel ppa?


I too have a MBP 7,1 and have experienced that same problems. The above driver seems to help with those issues. IT does have some of it's own quirks though but it is worth trying. I am using hte mutli-touch driver all of the time.

Before using the multitouch driver I had gotten used to making sure a good portion of the palm of my had was on the touchpad which seemed to make the disable touchpad while typing behavior work more reliably.

October 29th, 2010, 09:00 PM
thanks for the info. I installed it, and am trying it now.

I like the two finger scrolling, but still having problems with the pointer hopping around as I type text. the most frustrating thing is when it DELETES lines! argh..

It's really, really annoying. maybe I need therapy^^

November 3rd, 2010, 10:22 AM
I have given up for now. Too bad, I have been a loyal Ubuntu user for the past couple of years, but I guess I will have to use Mac OS X on my laptop, because the touchpad simply doesn't have the required drivers to function properly.

It "mostly" works, but the hyper active clicking that it does is just too frustrating. I will try again in a few months..

December 21st, 2010, 05:25 PM
After a while I have been looking around on the web for a solution I solved by disabling the mouse pad while using an external usb mouse.

I am using Ubuntu 10.04, so by following this indications I could disable the trackpad through the gpointing settings interface.


It can be an option.