View Full Version : [ubuntu] Printer problem after upgrade

October 28th, 2010, 03:42 PM
I have 2 PC's running Ubuntu in two different locations. Each PC has a connected Multifunctional printer type Canon Pixma MP260. Not the best choice for Ubuntu as it turned out.

I bought them when I was running Ubuntu 8.04. Ubuntu recognized the printer but didn't have a driver available. The forum gave some good advice so I downloaded a Canon Pixma MP240 driver at the Canon Software Download center. After this, the printer worked fine on both PC's.

I upgraded from 8.04 to 8.10 to 9.04 etc. without any problem. Last week, I upgraded both PC's to 10.10. The first system upgraded without a problem and still prints. The second system crashed during the upgrade. It was giving me a hard time to recover so I decided to reinstall the system partition with Ubuntu 10.10 from CD.

After having this done, the system is running smooth as ever but now I can't seem to install the Canon drivers anymore. It's giving me a hard time about libcupsys2 which isn't available. It's functions should be provided by libcups2 which is installed but this won't work. I tried to compile the driver but this failed. Tried to install libcupsys from older repo's but this also failed.

I would give up, if it wasn't for the fact that the upgraded system can print. So it IS possible to make the printer working, but the only available way to me is to reinstall Ubuntu 8.04 and then upgrade all the way to 10.10 again.

Does anyone understand this problem and perhaps knows of an easier way to get my printer working again ?

Thanks in advanced