PDA

View Full Version : [PPC] Cannot get Ubuntu 10.10 on my G4 iMac PPC



Krondaj
October 26th, 2010, 04:02 PM
Hi,

I decided as ubuntu 10.10 was so good on my old laptop i would install it on my old G4 iMac 17" LCD.

However, All I ever get is a black screen.

i tried the alternate install and it all seemed fine until it reboots and.... Black screen!

I burned the ubuntu 10.10 desktop ppc cdrom nice and slow, checked MD5 sums and verified disk etc...

I put it in the cd tray booted up, and let it starrt the lice cd... For a split second I saw the ubuntu loadscreen before it disappeard in a hiss of static and went to a.... Black screen.

I've tried alt-command F2, but donīt get a console

i am at a loss as to what to do next. I partitoned the whole HDD for ubuntu during the alternate istall. So until i can get Ubuntu up and running, I have a very heavy paperweight.


Can anybody help!?!

linuxopjemac
October 26th, 2010, 04:09 PM
You have a problem with Xorg.conf. Start with your Linux in yaboot with an "1" added, eg:

Linux 1
then login with root password and replace your xorg.conf:


wget http://mac.linux.be/files/xorg/imac8.txt
mv imac8.txt /etc/X11/xorg.conf
then CTRL-D to continue booting.

Krondaj
October 26th, 2010, 04:42 PM
Hi,

I haven't been able to put a password in as the live install blanks out before i can do anything.

Do I have to use the alternate install or can I use the live CD, which i'd prefer to use if possible

Beeblejj
October 26th, 2010, 06:34 PM
I have a iLamp G4, same problem and made a thread as well.
http://ubuntuforums.org/showthread.php?t=1605876
Still no luck as of yet.

marshag63
October 27th, 2010, 12:16 AM
Can you boot the live cd to text only mode?

I have 10.04 on an G4 iMac (iLamp) - would be glad to share my xorg.conf if you would like.

MarshaG63

Krondaj
October 27th, 2010, 08:52 AM
Hi marshag63,

I can't get the cd to boot in text only mode... Unfortunately my experience with Ubuntu has been with standard x86 machinesm - where you got a nice menu straight at the beginnning. I'm goin to try downloading, burning and running the alternate install for the iMac but last time I did this, it all went fine - and i rebooted (after removing CD) and it seemed fine - a couple of scrolls of text then it flickered (i assume when the video kicks in) and went to an inky black blank screen.

I'll try the alternate install and if it doesn't work i'll try to edit the Xorg.conf some how else the other option is to pull my hair out!!!

If you have your Xorg.conf file that would be great... Just got to get to a damn CL or something to do it!?!

Thanks

K

marshag63
October 27th, 2010, 01:25 PM
When you boot to the black screen, what happens when you press Ctrl + Alt + F1 to get to a terminal?

Will post my xorg.conf in about 9 hours or so, after work.

Do you get any options at the live-cd grub menu - press F1 and see what you get --- I will check what I get as well.

Be back later

MarshaG.

senorgomez
October 27th, 2010, 07:15 PM
I had this problem the first time I installed 10.10 on my ibook g4. The second time I made sure I was connected to the internet and everything worked out.

marshag63
October 28th, 2010, 12:37 AM
I booted my G4 iMac (iLamp) to get a look at the xorg.conf and was shocked to find it contains nothing! Zero bites. Yet, I have a working desktop install. I am baffled.

I could not get the live cd to boot to a command prompt - I just ended up with a yellow or orange screen. I am sure there is a live cd for powerPC that is only CLI - perhaps it was Finnix, or just a debian live cd.

I'm searching for an xorg.conf posting now. Be back when I know more.

MarshaG.

marshag63
October 28th, 2010, 12:47 AM
You may need to use recovery mode - it says to hold down shift at start-up

"Re: No xorg.conf found in /etc/X11 (Ubuntu 10.04)
Hi all. Just read this thread and figured I'd throw in what little knowledge I've gained so far. You can create an xorg.conf file by entering recovery mode (hold down shift at startup, or choose it from GRUB when it appears) and type:
Code:

sudo Xorg -configure

at the prompt."

Found that here: http://ubuntuforums.org/showpost.php?p=9431354&postcount=8

After some searching I found this xorg.conf for a G4 iMac:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "en"
Option "XkbOptions" "lv3:lwin_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "AccelFactor" "0.07"
Option "MinSpeed" "0.6"
Option "MaxSpeed" "1.3"
Option "SHMConfig" "true"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV34M [GeForce FX Go5200]"
Driver "nv"
BusID "PCI:0:16:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV34M [GeForce FX Go5200]"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection


MarshaG.

P.S. BTW, you should clear PRAM by holding down Command + Option + P + R keys - I let it chime at least 3 times before I try booting anything.

Beeblejj
November 29th, 2010, 01:34 AM
It hurts me to say this but I have tried everything else, and the only one that seemed to work well is YDL (yellowdog).

I will still used Ubuntu on my other computers!

http://www.yellowdoglinux.com/support/downloads/

linuxopjemac
November 29th, 2010, 09:03 AM
I can recommend MintPPC.

conal
November 30th, 2010, 12:13 PM
I always second the MintPPC call, however I borked my MintPPC installation trying to upgrade my Os x partition to Leopard.

Before I reinstall MintPPC I decided to try xubuntu to see how Maverick Meercat works. I used the Xubuntu 10.10 desktop cd, and to my surprise a number of things are working out-of the box - Everything is displaying correctly, and dvd's are mounting automatically.

I'll test everything I can before switching back to MintPPC and I'll post here for other iLamp users! I should point out that mine is a 1Ghz model (That in itself shouldn't make a difference but their might be other hardware differences between this and the 800Mhz or 1.25Ghz models).

Overall I prefer Debian/MintPPC anyway, but it would be good news for everyone if Ubuntu has a working PPC distribution as it's the first place a lot of people look when they think of switching to Linux, and I think there will be more folk coming over as the OS X POWER-PC is abandoned by many software developers.

Krondaj
March 29th, 2011, 10:12 PM
I've been away for a while and put the ilamp in the garage... I will have to dig it out and retry the suggestions above.. I'll let you know how it goes.

is MintPPC the linux mint fork of ubuntu??

K

linuxopjemac
March 29th, 2011, 10:43 PM
No:
http://mintppc.org/about

jimwg
April 8th, 2011, 12:06 PM
I have a 700mHz "iLamp" also, and used the alternate iso to install 10.10, and the furthest it boots-up is the black screen with white "Ubuntu" print above four dots of which only about three turn red in the boot-up before it stalls. Using the Tab key and "Linux 1" in the boot line during boot-up doesn't work as recommended here. Much appreciate any suggestions. Thanks!

JimWG

linuxopjemac
April 9th, 2011, 01:05 AM
try booting with
Linux 1 nosplash

jimwg
April 9th, 2011, 03:15 AM
try booting with
Linux 1 nosplash

Okay, I typed "Linux 1 nosplash" at the boot: startup prompt and got:

fsck from util-linux-ng 2.17.2
/dev/hda3: clean, 110981/2395568 files, 711140/9580544 blocks
skipping profile in /etc/apparmor .d/disable: usr.bin.firefox
[34.810034] fb: conflicting fb hw usage nouveaufb vs Offb-NVDA, MUMac

Then it stalled,

Thanks for swift response!

linuxopjemac
April 9th, 2011, 09:12 AM
I don't know what it means but it seems related to nouveau, see other thread where I responded to your question:
http://ubuntuforums.org/showthread.php?t=1724704