PDA

View Full Version : [ubuntu] HP DV7 with Beats Audio



BadPenguin86
October 25th, 2010, 10:33 PM
I have an HP DV7 with Beats audio. Ubuntu can use the crappy laptop speaker, but not the good beats speakers. help?

Racecar56
October 25th, 2010, 10:37 PM
I have an HP DV7 with Beats audio. Ubuntu can use the crappy laptop speaker, but not the good beats speakers. help?
Assuming those plug into the laptop's headphone jack, Ubuntu apparently doesn't support using the headphone jack on your laptop. Maybe you should post the output of this command:


lspci|grep Audio

Do the main speakers mute when you plug in those speakers? If not then Ubuntu isn't catching the fact that you plugged those in.

BadPenguin86
October 26th, 2010, 01:32 AM
I should have explained better.. There are two sets of speakers in the laptop, the beats audio, and regular speakers. Ubuntu can use the regular speakers, but not the good beats speakers. Headphone jack works fine. Here is the output just to be complete:


justin@jpubuntu:~$ lspci|grep Audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
02:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series] (rev ff)

Racecar56
October 26th, 2010, 10:20 AM
I should have explained better.. There are two sets of speakers in the laptop, the beats audio, and regular speakers. Ubuntu can use the regular speakers, but not the good beats speakers. Headphone jack works fine. Here is the output just to be complete:
justin@jpubuntu:~$ lspci|grep Audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
02:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series] (rev ff)

Not sure about that then. :(
offtopic: yay ATI
F
Edit: Did some searching, no avail.

igorbb
November 12th, 2010, 07:29 PM
I'm also in the same situation.

Any news ?

lidex
November 13th, 2010, 04:29 AM
Start here. Use the alsa-info-script to provide detailed information.
Run this command in a terminal:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
Choose the upload option and provide a link for the output.
[Terminal="Applications->Accessories->Terminal"]

igorbb
November 27th, 2010, 09:41 PM
http://www.alsa-project.org/db/?f=9f556618f3688ed22fb507f15097a9bf82e1cd77

lidex
November 28th, 2010, 12:23 AM
http://www.alsa-project.org/db/?f=9f556618f3688ed22fb507f15097a9bf82e1cd77

Try this for me please. Using a Terminal="Applications->Accessories->Terminal"
Open this file for editing:

gksudo gedit /etc/modprobe.d/alsa-base.conf
Insert this line at the bottom:

options snd-hda-intel model=hp-dv5 enable_msi=1
Save. Close. Reboot.
Check your levels in alsamixer.

alsamixer
Press <F6> to select the correct soundcard.
Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
On the output tab choose the correct device.

stephenjbarr
January 3rd, 2011, 08:18 PM
Any progress on getting the subwoofer to work?

Colonel_Ingus
January 20th, 2011, 08:53 PM
Pavilion dv7 here, got beats, haven't ever heard it work. I blasted win7 out of it as soon as I got it out of the box.

Any idea how to get beats audio to work?

Colonel_Ingus
January 20th, 2011, 08:58 PM
Pavilion dv7 here, got beats, haven't ever heard it work. I blasted win7 out of it as soon as I got it out of the box.

Any idea how to get beats audio to work?

Colonel_Ingus
January 20th, 2011, 09:01 PM
Pavilion dv7 here, got beats, haven't ever heard it work. I blasted win7 out of it as soon as I got it out of the box.

Any idea how to get beats audio to work?

Colonel_Ingus
January 20th, 2011, 09:04 PM
Pavilion dv7 here, got beats, haven't ever heard it work. I blasted win7 out of it as soon as I got it out of the box.

Any idea how to get beats audio to work?

BadPenguin86
January 25th, 2011, 01:17 PM
None of those methods worked. Still using only the fallback (tiny) speakers.

SebSmith
January 31st, 2011, 02:16 AM
did this work?

same problem here.

igorbb
February 8th, 2011, 01:38 PM
No ..
Nothing Works so far.

Colonel_Ingus
February 24th, 2011, 09:05 PM
Still needing to know how to get this thing to work...

SebSmith
February 26th, 2011, 05:28 AM
Start here. Use the alsa-info-script to provide detailed information.
Run this command in a terminal:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh Choose the upload option and provide a link for the output.
[Terminal="Applications->Accessories->Terminal"]

Your ALSA information is located at http://www.alsa-project.org/db/?f=cf5ee9a0cca73a4bc4869e3bcb9d8ed90f7b9d0f

Temüjin
February 26th, 2011, 03:04 PM
Your ALSA information is located at http://www.alsa-project.org/db/?f=cf5ee9a0cca73a4bc4869e3bcb9d8ed90f7b9d0f
Your ALSA install is borked (no kernel module/driver loaded). You might want to try the ALSA upgrade script (or the daily Natty/11.04 LiveCD) to see if using a more recent ALSA helps.

SebSmith
February 26th, 2011, 05:27 PM
Your ALSA install is borked (no kernel module/driver loaded). You might want to try the ALSA upgrade script (or the daily Natty/11.04 LiveCD) to see if using a more recent ALSA helps.


how do i do this?

Temüjin
February 26th, 2011, 05:28 PM
http://ubuntuforums.org/showthread.php?t=1681577

SebSmith
February 26th, 2011, 06:02 PM
http://ubuntuforums.org/showthread.php?t=1681577

no avail. script works fine, sound card still undetected. any other ideas? and i really appreciate this

magatsu
April 8th, 2011, 06:21 PM
same here, i have a DV7 4180us, and the sound is awfull, we really need Beats Audio in ubuntu ;__;

whiteskate
April 21st, 2011, 06:49 PM
Hello,

I searched everywhere to find out how to get the sub to work and i finally found a HP forum.


Just add this line to the end of the conf file,
options snd-hda-intel model=ref

In this file :
(sudo gedit /etc/modprobe.d/alsa-base.conf)

And restart your computer



Link to where I found out how to do this

http://h30434.www3.hp.com/t5/Notebook-Operating-systems-and/quot-Beats-Audio-quot-Linux-HP-Envy-17/td-p/520175



I also updated my Alsa drivers to v1.0.23
I used the attached file to update my alsa drivers


I am New to the linux/ubuntu world, I will try and help with what i can but i am simply using what others have already done.

Faz1
May 29th, 2011, 02:44 PM
Works like a charm!
Thanks whiteskate!!! :)

Quality first post! =D>
I can finally enjoy my new HP!!! :guitar:

NexusZA
May 31st, 2011, 01:32 PM
Hello,

I searched everywhere to find out how to get the sub to work and i finally found a HP forum.


Just add this line to the end of the conf file,
options snd-hda-intel model=ref

In this file :
(sudo gedit /etc/modprobe.d/alsa-base.conf)

And restart your computer



Link to where I found out how to do this

http://h30434.www3.hp.com/t5/Notebook-Operating-systems-and/quot-Beats-Audio-quot-Linux-HP-Envy-17/td-p/520175



I also updated my Alsa drivers to v1.0.23
I used the attached file to update my alsa drivers


I am New to the linux/ubuntu world, I will try and help with what i can but i am simply using what others have already done.

Adding that line actually stopped my sound from working entirely.

lawrencesilva
August 25th, 2011, 12:49 AM
hi guys im using a dv7-6135dx and got the two main speakers working (right out of the box),

but still wanting to have the other two front speakers and the subwoofer to work.

ive tried adding this:

options snd-hda-intel model=ref

via: /etc/modprobe.d/alsa-base.conf

rebooted. and noticed that sound output was REVERSED. now the two main speakers aren't working but the two small front speakers and subwoofer are working.

sigh... the only problem now is to make them work together all at the same time. :(

help. :confused:

lidex
August 25th, 2011, 02:07 AM
hi guys im using a dv7-6135dx and got the two main speakers working (right out of the box),

but still wanting to have the other two front speakers and the subwoofer to work.

ive tried adding this:

options snd-hda-intel model=ref

via: /etc/modprobe.d/alsa-base.conf

rebooted. and noticed that sound output was REVERSED. now the two main speakers aren't working but the two small front speakers and subwoofer are working.

sigh... the only problem now is to make them work together all at the same time. :(

help. :confused:

What is your amixer output:

amixer
And what profile is selected in sound preferences?

lawrencesilva
August 25th, 2011, 02:54 AM
dv7:~$ amixer
Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
Playback channels: Mono
Limits: Playback 0 - 64
Mono: Playback 46 [72%] [-13.50dB] [on]
Simple mixer control 'Headphone',0
Capabilities: pvolume pswitch penum
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Mono:
Front Left: Playback 64 [100%] [0.00dB] [on]
Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
Capabilities: pvolume pswitch penum
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Mono:
Front Left: Playback 0 [0%] [-48.00dB] [on]
Front Right: Playback 0 [0%] [-48.00dB] [on]
Simple mixer control 'PCM',0
Capabilities: pvolume penum
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front Mic Jack Mode',0
Capabilities: enum
Items: 'Mic In' 'Line In'
Item0: 'Mic In'
Simple mixer control 'Mic',0
Capabilities: cvolume penum
Capture channels: Front Left - Front Right
Limits: Capture 0 - 3
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control 'IEC958',0
Capabilities: pswitch pswitch-joined penum
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'Beep',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
Playback channels: Mono
Limits: Playback 0 - 3
Mono: Playback 3 [100%] [0.00dB] [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch penum
Capture channels: Front Left - Front Right
Limits: Capture 0 - 15
Front Left: Capture 0 [0%] [0.00dB] [on]
Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control 'Digital',0
Capabilities: cvolume penum
Capture channels: Front Left - Front Right
Limits: Capture 0 - 120
Front Left: Capture 60 [50%] [0.00dB]
Front Right: Capture 60 [50%] [0.00dB]
Simple mixer control 'Internal Mic',0
Capabilities: cvolume penum
Capture channels: Front Left - Front Right
Limits: Capture 0 - 3
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]

profile: analog stereo duplex

thanks for the reply. :)

lidex
August 26th, 2011, 02:19 AM
I'm not sure how the outputs are attained. Maybe you can ask one of the others who got it working if they used a surround profile.
Have you tried raising this level:

Simple mixer control 'Speaker',0
Capabilities: pvolume pswitch penum
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Mono:
Front Left: Playback 0 [0%] [-48.00dB] [on]
Front Right: Playback 0 [0%] [-48.00dB] [on]

sharat90
September 11th, 2011, 09:09 AM
here's what worked for me.

goto sound preferences > output

and in Connector choose Analog Speakers. now you should get output from all four speakers.

but when you connect headphones output continues from the front speakers (subs). in that case choose analog output as the connector.

hope this helps..

lawrencesilva
September 16th, 2011, 03:25 AM
man. you're correct! now all of my laptop's 4+1 speakers are working! only problem now is you need to switch it back to the other setting for you to use a headphone and turn off the external speakers.

guys any idea how to deal with this issue? thanks y'all

Evandar
October 9th, 2011, 10:18 PM
man. you're correct! now all of my laptop's 4+1 speakers are working! only problem now is you need to switch it back to the other setting for you to use a headphone and turn off the external speakers.

guys any idea how to deal with this issue? thanks y'all

I am a bit late, so you might have found it, but to do that, you just change your output to Analogue Headphones instead of Analogue Output in the "Output" Tab on your Sound Preferences.

On the subject of this thread (hoping that it's not dead yet), while the HP forums solution works, the speakers give a distorted output when the volume is cranked up - it sounds like someone has added a killswitch and a fuzz effect on top of the output - on my dv7 4050ea. I really can't remember what Windows 7 sounded like, but I would certainly remember it if it sounded like THAT. Seeing as I know a few things about sound mixing, I can tell that the computer is playing the wrong frequencies out of the wrong speakers - for example, playing high frequencies loudly on the subwoofer. Anyone know what I have to edit to make the right frequencies route to the right speakers? Should I be asking this in sound?

btw, I'm using Natty.