PDA

View Full Version : [SOLVED] Cannot disable Unity



thef0rce
October 24th, 2010, 10:10 AM
Hi,

I upgraded to Maverick recently on my netbook. I was using the old netbook remix with the launcher. Unity is too slow and buggy for day to day use. I selected Ubuntu desktop edition in the menu at the login screen and logged in, but Unity started up anyway. Does anyone have any ideas on how to make Unity go away?

Thanks

sanderd17
October 24th, 2010, 10:25 AM
You clould remove unity, I've done it.

Go in the terminal and execute


sudo aptitude search unity

and


sudo aptitude search netbook


And for every package on which you see an 'i' left to the package name: execute


sudo aptitude remove [PACKAGE]

with [PACKAGE] the packagename.

Finally, be sure the desktop edition is installed:



sudo aptitude install ubuntu-desktop

thef0rce
October 24th, 2010, 10:53 AM
I tried just uninstalling it once and had no GUI after login. I think the links on the login screen have been altered. If anyone knows what files actually control the configuration of the login screen, it would be helpful

sanderd17
October 24th, 2010, 10:57 AM
can you login via the CLI and then execute



startx

thef0rce
October 24th, 2010, 11:08 AM
how do I login via the CLI in ubuntu? It isn't the recovery console. That has a display manager

sanderd17
October 24th, 2010, 11:12 AM
sorry, didn't read that good, so you can login via GUI but after your login, you only get a CLI?

well, then execute the startx command.

If you can't login, press CTRL+ALT+F1 and you'll get a way of logging in via the CLI.

thef0rce
October 24th, 2010, 11:21 AM
No. The problem is even if I choose to start up ubuntu desktop and not the netbook version, I get the netbook interface. I don't like Unity, it crashes all the time. I just want to go back to using gnome. I must have messed up the desktop edition link, maybe linked it to something else, but I can't figure out what I did to get to this point.

I've uninstalled unity once and it didn't go well so I reinstalled it and now I'm back to my original problem. So I think there must be a way to solve this without nuking Unity from my system

thef0rce
October 24th, 2010, 11:43 AM
Ha I solved my own problem. At some point I seem to have symlinked the default configuration for gnome to the default configuration for the netbook remix.

For others who may have this problem, the default configuration files are in


/usr/share/gconf/defaults


for the desktop edition. Any symlinks referring to une should be deleted.

Then do



sudo update-gconf-defaults


and logout and log back in to the desktop edition and Unity will be gone :)

sanderd17
October 24th, 2010, 12:18 PM
congrats,

I wouldn't have found this.

mdmcginn
April 30th, 2011, 03:52 PM
The method described only works if your login screen gives you options to log in with a different mode, which mine doesn't. But you can change back to Ubuntu Classic using the Ubuntu System Settings (you can always change it back to Unity later).

1) Click on the power button in the upper right corner (mine looks like a light switch) and choose the last option, System Settings.
2) Search for Login Screen
3) Double-click to display
4) Choose Unlock and enter your password
5) Select Ubuntu Classic as default session.

11.04eli
May 15th, 2011, 05:51 PM
You are all wrong. To disable Ubuntu Unity, turn off your computer and turn it back on again (restart) and then select 'Ubuntu Classic Edition' at the bottom. To turn back on, simply change back to 'Ubuntu Desktop Edition' when you log in. :guitar:

llanitedave
May 15th, 2011, 08:43 PM
Thanks for this. I gave Unity what I consider a fair try, but I couldn't make myself like it. It's simply too disorganized by default, and too convoluted for me to organize easily. It's got a bit of growing up to do.

war59312
May 15th, 2011, 11:54 PM
Agree. It should have asked during the upgrade/install if you wish to use Unity or not.

I hate it! Thanks for the helpful tips. Looking good.


You are all wrong. To disable Ubuntu Unity, turn off your computer and turn it back on again (restart) and then select 'Ubuntu Classic Edition' at the bottom. To turn back on, simply change back to 'Ubuntu Desktop Edition' when you log in. :guitar:Really should watch your language.

That IS wrong too if you want to be like that.

I don't even get that choice, since auto login is enabled.

So the point: Stop assuming everyone else is wrong and only you are right.

pepa007
June 21st, 2011, 10:18 PM
The method described only works if your login screen gives you options to log in with a different mode, which mine doesn't. But you can change back to Ubuntu Classic using the Ubuntu System Settings (you can always change it back to Unity later).

1) Click on the power button in the upper right corner (mine looks like a light switch) and choose the last option, System Settings.
2) Search for Login Screen
3) Double-click to display
4) Choose Unlock and enter your password
5) Select Ubuntu Classic as default session.

this works fine. thanks.

DavidBiesack
January 4th, 2012, 03:08 PM
1) Click on the power button in the upper right corner (mine looks like a light switch) and choose the last option, System Settings.
2) Search for Login Screen
...

I guess I'm hosed because my search for "Login Screen" or "Login" does not match anything. I can see Appearance, Display, Users Accounts, etc. The only match for "screen" is for setting screen brightness.

Is there a gconf setting for this? Or a file setting that I can edit in emacs?