View Full Version : [ubuntu] Can't enable Mobile broadband connection

Chauhan Ankit
October 20th, 2010, 09:27 AM
Hello all,
I am new to linux, so i downloaded ubuntu 10.10 for learning purpose. All goes well, i installed it successfully.
The problem which i face is that when i connected my mobile broadband device, ubuntu detects it and i have succesfully made the connection.
But the network Manager is showing "disable" Mobile Broadband connection. I tried to put a check on Enable Mobile Broadband but can't check it. So i can't access Internet in ubuntu.
-> I think some offline package installation should be there to resolve the problem, or some console commands.:confused:
-> I tried to use the (wvdial) which i use at Backtrack. but i think ubuntu did not have.:(
Help me guys to connect to Internet:)

October 20th, 2010, 09:59 AM
when the connection is established with Network Manager
right click on Network Manager and select Connection Information

Post contents of

IP Address :
Broadcast Address:
Primary DNS:
Secondary DNS:


October 29th, 2010, 01:37 PM
I have this exact same problem. I was able to set up a connection and select the correct device but when I look under the network connections icon it says the mobile broadband is disabled. When I click on it to enable mobile broadband the window closes but nothing changes. It will not enable.

Please advise.



October 31st, 2010, 12:17 PM
Hi, Same problem on HP mini 5101..

November 13th, 2010, 09:08 PM
SAME HERE Samsung RF510... Ubuntu 10.10

November 14th, 2010, 10:23 PM
Ok I use a sprint mobile broadband card usb model . Right click the network manager . Click on edit connections . I don't use anything but my broadband card . You will see auto etho . Highlight that and uncheck connect automatically . Next click on mobile broadband and then click on add . Then choose your company . Follow the prompts .

December 19th, 2010, 06:00 AM
To enable Mobile broadband this is the solution AFAIKW and it works for me(HUAWEI BSNL):

sudo gedit /etc/rc.local

and add the following line before the line 'exit' :
##Note: Include appropriate modprobe cmd.

sudo modprobe usbserial vendor=0x12d1 product=0x1010

If you are using modprobe **** and then wvdial cmd, then I hope it will work for you.