PDA

View Full Version : [ubuntu] Default media player in Google Chrome



voutasaurus
October 19th, 2010, 03:02 PM
Hi there.

I'm running Ubuntu 10.04 Desktop, and I'm using Google Chrome as a browser.

Every time I open any video file in the browser, it automatically uses the Totem Movie Player plugin to play it. I would prefer it to use the VLC plugin as a default (I do have the plugin installed). I've tried to find the option in Chrome's preferences, and I checked my plugins, and when I disable the Totem plugin, videos don't play in the browser at all.

I figure it should be simple, so I figure maybe I'm missing something.

Any help would be appreciated. Thanks. :)

sohlinux
October 19th, 2010, 06:43 PM
Right click on the video file and select Properties. then Choose the Open With, go to other then go to applications - sound and video and select VLC Player. tick remember application association. done!

voutasaurus
October 19th, 2010, 11:12 PM
Okay, ignore Chrome for a second.

Within Nautilus, I right clicked on an avi file and opened it with vlc and ticked the box for "Remember this application for "AVI video" files". I open the file a second later and it opens with Totem. mp4s open with vlc every time, and wmvs open with Totem, even if I do the same thing as with the avi file.

Is there a file somewhere which overrides these preferences which I could edit?

sohlinux
October 19th, 2010, 11:32 PM
Okay, ignore Chrome for a second.

Within Nautilus, I right clicked on an avi file and opened it with vlc and ticked the box for "Remember this application for "AVI video" files". I open the file a second later and it opens with Totem. mp4s open with vlc every time, and wmvs open with Totem, even if I do the same thing as with the avi file.

Is there a file somewhere which overrides these preferences which I could edit?

easiest would be to remove Totem if you dont use it then VLC will become default

mc4man
October 19th, 2010, 11:56 PM
Within Nautilus, I right clicked on an avi file and opened it with vlc and ...
To change the default for a mimetype use r. click - properties - open with

If you installed the vlc mozilla plugin then remove the totem-mozilla plugin - you should only have 1 browser plugin installed at a time

Chipzzz
December 10th, 2010, 01:27 AM
I recently solved a similar problem with Chrome and mms streams this way:

Open: Applications/System Tools/Configuration Editor
Go to: desktop/gnome/url-handlers/mms
Right click, Edit, and change: 'totem "%s"' to 'vlc "%s"'

All done!

This should work similarly for any file or stream type.

Good luck :)

nathan.f77
February 25th, 2012, 05:23 PM
Awesome, thanks Chipzzz, your solution worked for me.

But instead of "Open: Applications/System Tools/Configuration Editor", just go to Terminal and type "gconf-editor".