View Full Version : [ubuntu] Touchpad behavior in Maverick on Macbook 5,1

October 18th, 2010, 10:39 PM
Hey guys,

So I've been forced to use ubuntu for various things at work now, and I'm trying to get settled in. However, one serious problem I've had is getting my touchpad to be anywhere usable.

Since there isn't any sort of Maverick-related info page, I've been checking out the stuff for MacBookPros. In fact I'm pretty sure they all have the same trackpad anyway.

This is what I was looking at:

They mention that "click and drag" works. Does that mean click and drag with one finger, or click and drag one finger clicking and the other "dragging"

My main problems are that I currently am accidentally activating the double-tap automatic drag accidentally. Secondly is anyone able to do the two-finger drag?

I've managed to get two-finger scrolling going though.

It's really unusable right now though. I really need that two-finger click-drag though.

I also managed to change some of the settings via synclient, but never really got it working to where it wasn't constantly getting in the way.

Niels den Otter
October 19th, 2010, 08:39 PM
I'm not sure what parameters you would want to change, but the synaptics driver gives lot of options. What I change myself at login is following:

more ~/otter@sambal:~$ more ~/bin/startup.sh

xinput set-prop "bcm5974" "Synaptics Palm Detection" 1
xinput set-prop "bcm5974" "Synaptics Locked Drags" 1

The following URL provides a long list of possible parameters (not sure if it is the latest):


Good luck,


October 23rd, 2010, 07:22 PM
Thanks for the help Niels, I actually just found what I was looking for here, for future reference:


October 23rd, 2010, 10:02 PM
Hi, I just installed Ubuntu today would like to know what the solution is (step by step if possible). I'm not really sure if I'm running the synaptics driver or not... nothing is mentioned in xorg.conf.

Can anyone help me?

Edit: Ah, so there already was a step by step solution here (http://ubuntuforums.org/showpost.php?p=9193610&postcount=130), guess I didn't look close enough.