PDA

View Full Version : [ubuntu] 10.10 install - The package system is broken



dinamic1
October 18th, 2010, 11:22 AM
Ok, so i just installed ubuntu 10.10 from CD. After restart the Update Manager windows poped up and downloaded 21 updates.. but i can't install the updates because "The package system is broken.." http://i.imgur.com/LvNXk.png

it's a fresh istall i didn't installed nothing i didn't do nothing

dinamic1
October 18th, 2010, 11:30 AM
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6 : Depends: libc-bin (= 2.12.1-0ubuntu6) but 2.12.1-0ubuntu7 is installed
libc6-dev : Depends: libc6 (= 2.12.1-0ubuntu7) but 2.12.1-0ubuntu6 is installed
E: Unmet dependencies. Try using -f.

mrgs
October 18th, 2010, 11:40 AM
You might want to run 'apt-get -f install' to correct these.

dinamic1
October 18th, 2010, 12:07 PM
ok so after > apt-get -f install libc6 libc6-dev .. and then restart. now i get this error
http://i.imgur.com/Sw4Ly.png

dinamic1
October 18th, 2010, 12:11 PM
so.. i clicked on Partial update
http://i.imgur.com/Xgy7L.jpg

Why is it so buggy? fresh install

ghadam
October 18th, 2010, 04:04 PM
Installed 10.10 an hour ago and had the same problem with libc6. Typed nothing but "apt-get install -f" in terminal and now it works without any error messages. Don't know much about the system, but is it important, that you have typed "apt-get -f install libc6 libc6-dev" instead of what I typed? (Sorry for my English)

TiSer
April 11th, 2013, 08:43 AM
I have the same problem with lib " libavdevice52 ".
I had tried "apt-get -f install":



Err http://ua.archive.ubuntu.com/ubuntu/ maverick-updates/main libavdevice52 i386 4:0.6-2ubuntu6.3
404 Not Found [IP: 91.189.92.200 80]
Err http://security.ubuntu.com/ubuntu/ maverick-security/main libavdevice52 i386 4:0.6-2ubuntu6.3
404 Not Found [IP: 91.189.92.200 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/f/ffmpeg/libavdevice52_0.6-2ubuntu6.3_i386.deb 404 Not Found [IP: 91.189.92.200 80]

and "Complete Removal" from Synaptic, but every time I have the same error:


E: Unable to correct missing packages
W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/universe/f/ffmpeg-extra/libavutil-extra-50_0.6-2ubuntu3.3_i386.deb
404 Not Found [IP: 91.189.92.200 80]
W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/multiverse/f/ffmpeg-extra/libavcodec-extra-52_0.6-2ubuntu3.3_i386.deb
404 Not Found [IP: 91.189.92.200 80]
W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/multiverse/f/ffmpeg-extra/libavformat-extra-52_0.6-2ubuntu3.3_i386.deb
404 Not Found [IP: 91.189.92.200 80]
W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/multiverse/f/ffmpeg-extra/libavdevice-extra-52_0.6-2ubuntu3.3_i386.deb
404 Not Found [IP: 91.189.92.200 80]

Synaptic every time show me "STOP" sign on panels.

What should I do? Maybe I can delete already installed broken files from libavdevice52 ?
Help, pls!

lisati
April 11th, 2013, 09:01 AM
If a post is older than a year or so and hasn't had a new reply in that time, instead of replying to it, create a new thread. In the software world, a lot can change in a very short time, and doing things this way makes it more likely that you will find the best information. You may link to the original discussion in the new thread if you think it may be helpful.

If you are using 10.10, you might want to consider using a newer version of Ubuntu. 10.10 is past its "use by" date.