PDA

View Full Version : [ubuntu] Simple wireless problem



Sequoia Bird
October 18th, 2010, 03:16 AM
My wireless basically just quit on me in v10.04. I saw there was a 10.10, so I downloaded it hoping that it would fix my problem.

I have a Dell inspiron 1564, the wireless is enabled according to the network manager, when I type "rfkill list" into terminal it says wireless is

hard blocked: no
soft blocked: yes

My wifi card is a broadcom BCM4312... The additional driver I have for it is Broadcom STA wireless driver... The ethernet cable will let me have internet with absolutely no trouble. I tried "connect to hidden wireless network" with searching but no finding...

Thanks for the help! I've been at this all day and i'm starting to feel really stupid.

johnnytm
October 18th, 2010, 03:29 AM
try this
rfkill unblock all

Sequoia Bird
October 18th, 2010, 04:41 AM
Perfect, it took a little bit of poking around after but it worked. Thanks!

johnnytm
October 18th, 2010, 07:22 PM
Good to hear, glad it worked.

TBABill
October 18th, 2010, 10:41 PM
Is that a permanent fix or does it require being done every reboot?

johnnytm
October 19th, 2010, 01:07 AM
if it is still requiring it on reboot there is a command to add it to rfkill conf . I just have to find it again, but will post it as soon as i find it. I like to try and make sure I'm not just adding to conf files from memory all the time.lol

johnnytm
October 19th, 2010, 01:50 AM
I believe it to be a permanent fix. After checking my rfkill bin bash file it changes that. which does which does not revert after reboot. the soft block you were getting was software related, hard blocks are harder to deal with. Let me know if you are still having problems tho. there are a couple of other things that can be checked.