View Full Version : [SOLVED] 10.04 Accidentally Erased /var

October 16th, 2010, 12:52 PM
Yes, you read that right, yes it's incredibly stupid, yes I like to mess with my machine (too much). I tried to upgrade to 10.10, but I needed more room on /var. So I tried to clean up /var. first I did the standard stuff, apt-get autoclean and clean etc. Which wasn't enough. So I tried to be a bit more thorough. I was VERY thorough, what I did basically amounts to "sudo rm /var/* -r" and thus I'm stuck with a problem. My package managers don't know what's installed anymore. Thus I cannot install anything else anymore, since it all depends on something. Whenever I try to dist-upgrade I run into errors. Is there any way to rebuilt things? I would be very happy if someone could help me out with this problem.


Whenever I try to dist-upgrade I run into errors.Like:
sudo apt-get dist-upgrade
E: Could not perform immediate configuration on 'libattr1'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

sudo apt-get dist-upgrade -oAPT::Immediate-Configure=0
E: Couldn't configure pre-depend perl-base for liblocale-gettext-perl, probably a dependency cycle.

EDIT2: Nevermind, I couldn't relog into my XServer, so I backed up my stuff to the Windows 7 partition from terminal and reinstalled.